Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

compile error with boost 1.45 / 1.44 #1176

Closed
springmeyer opened this Issue · 2 comments

1 participant

@springmeyer
Owner
include/mapnik/expression_grammar.hpp:243:24: error: use of undeclared identifier 'lexeme'; did you mean 'boost::spirit::lexeme'?
        attr %= '[' >> lexeme[+(char_ - ']')] >> ']';
                       ^~~~~~
                       boost::spirit::lexeme
@springmeyer
Owner

thx @zerebubuth for spotting.

@springmeyer
Owner

ack, broken 1.42:

include/mapnik/expression_grammar.hpp: In constructor 'mapnik::expression_grammar<Iterator>::expression_grammar(const mapnik::transcoder&)':
include/mapnik/expression_grammar.hpp:142: error: 'mapnik::qi::no_skip' has not been declared
@zerebubuth zerebubuth referenced this issue from a commit in MapQuest/mapnik
@springmeyer springmeyer close #1176 again a4b3daf
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.