OS X dylib compatibility names #322

Closed
artemp opened this Issue Oct 11, 2011 · 1 comment

Comments

Projects
None yet
1 participant
Owner

artemp commented Oct 11, 2011

These are not properly getting added to the library... need to look into why:

{{{
$ otool -L /opt/local/lib/libmapnik.dylib
/opt/local/lib/libmapnik.dylib:
/opt/local/lib/libmapnik.dylib (compatibility version 0.0.0, current version 0.0.0)
/opt/local/lib/libfreetype.6.dylib (compatibility version 10.0.0, current version 10.20.0)
}}}

Owner

artemp commented Oct 11, 2011

[springmeyer] Ah, pretty easy to add, just specify the ABI versions as linker args.

Done in r1108.

Now a bit a research is needed to determine ABI changes and track their compatibility.

@artemp artemp closed this Oct 11, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment