Restore behavior of MapServer 4.10 for WMS STYLES parameter #2427

Closed
mapserver-bot opened this Issue Apr 3, 2012 · 2 comments

Projects

None yet

2 participants

@mapserver-bot

Reporter: dmorissette
Date: 2007/12/06 - 23:07
Trac URL: http://trac.osgeo.org/mapserver/ticket/2427
Ticket #1088 enforced the requirement of a number of WMS request parameters in GetMap and GetFeatureInfo URLs in MapServer 5.0.

Enforcing the requirement for the STYLES parameter in MapServer 5.0 has led to issues with a couple of WMS clients, the main one being that GoogleEarth could no longer connect to MapServer WMS services (others such as JUMP were reported to have the same issue).

A long thread of discussions followed, including the development of RFC-35 as a possible solution, and the submission of a change request at OGC to make STYLES optional in the next revision of the spec since it really doesn't need to be required (as was agreed on the wms-dev list). In the end we figured that the best solution was to withdraw RFC-35 and simply revert this change in 5.0.1 and make the STYLES parameter optional again (as it was in v4.10).

This ticket is to document and track this change.

@mapserver-bot

Author: dmorissette
Date: 2007/12/07 - 21:35
Fixed. STYLES made optional again in 30ae679 (r7156) (trunk) and 7c884f8 (r7157) (branch-5-0).

@mapserver-bot

Author: tomkralidis
Date: 2007/12/08 - 22:58
FYI I've updated http://mapserver.gis.umn.edu/docs/faq/ogc-wms-getmap-required-parameters to reflect this change.

@dmorissette dmorissette was assigned Apr 5, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment