MetadataURL is wrong encoded in the WFS 2.0 Capabilities #4886

Closed
JuergenWeichand opened this Issue Mar 20, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@JuergenWeichand
Contributor

JuergenWeichand commented Mar 20, 2014

The optional MetadataURL-link to the ISO 19139 Metadata is wrong encoded in the WFS 2.0 Capabilities-Document.

Example

http://geoserv.weichand.de/cgi-bin/mapserv-dev?map=/home/wei/wfs20-example.map&service=WFS&acceptversions=2.0.0&request=GetCapabilities

https://github.com/JuergenWeichand/geospatial-webservices-examples/blob/master/mapserver/wfs/wfs20-example.map

Current implementation

 <MetadataURL format="text/html" type="FGDC">http://...</MetadataURL>

Correct implementation

<MetadataURL xlink:href="http://...." />

Best regards
Juergen Weichand

rouault added a commit that referenced this issue Mar 20, 2014

rouault added a commit to mapserver/msautotest_DEPRECATED that referenced this issue Mar 20, 2014

@rouault rouault added the WFS Server label Mar 20, 2014

@rouault rouault self-assigned this Mar 20, 2014

@rouault

This comment has been minimized.

Show comment
Hide comment
@rouault

rouault Mar 20, 2014

Contributor

Thanks for notifying us about this. MetadataURL generation was not tested in any WFS version up to now...

Contributor

rouault commented Mar 20, 2014

Thanks for notifying us about this. MetadataURL generation was not tested in any WFS version up to now...

@rouault rouault closed this Mar 20, 2014

@JuergenWeichand

This comment has been minimized.

Show comment
Hide comment
@JuergenWeichand

JuergenWeichand Mar 24, 2014

Contributor

Great thanks!

Contributor

JuergenWeichand commented Mar 24, 2014

Great thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment