Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WMS-dimensions on 6.5-dev not working properly #5032

Closed
deduikertjes opened this issue Nov 7, 2014 · 5 comments
Closed

WMS-dimensions on 6.5-dev not working properly #5032

deduikertjes opened this issue Nov 7, 2014 · 5 comments
Assignees
Milestone

Comments

@deduikertjes
Copy link

@deduikertjes deduikertjes commented Nov 7, 2014

Hi,

I'm using WMS-dimensions as described on http://mapserver.org/ogc/wms_dimension.html. This is working fine in mapserver 6.4.1.

When using WMS Dimensions on 6.5-dev (checked out from GitHub on 5-11-2014) I get the following exception report when doing a getmap request with paramters like: &DIM_QUALITY=0.9/1&DIM_LINEAR=-1/0,0/1:


msDrawMap(): Image handling error. Failed to draw layer named 'jan2014_low'.
msPostGISLayerWhichShapes(): Query error. Error executing query: ERROR: operator does not exist: >= numeric
LINE 1: ...32.505600397 6790506.21879132))',900913) and (((( >= 0.90000...
^
HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts.

MArco

@tbonfort tbonfort added this to the 7.0 Release milestone Nov 7, 2014
@sdlime
Copy link
Member

@sdlime sdlime commented Nov 12, 2014

Got it. @deduikertjes, any chance you have a small test case available?

Steve

@deduikertjes
Copy link
Author

@deduikertjes deduikertjes commented Nov 13, 2014

Hi Steve,

I'm happy to provide a test case.

What would you like to have? Mapfile + data? Or only an URL from a service.
I prefer to make this test case non public (data is not mine). So maybe
we can discuss this further on PM?

MArco

On 12-11-14 17:13, Steve Lime wrote:

Got it. @deduikertjes https://github.com/deduikertjes, any chance
you have a small test case available?

Steve


Reply to this email directly or view it on GitHub
#5032 (comment).

@sdlime
Copy link
Member

@sdlime sdlime commented Nov 13, 2014

Ideally I'd need a mapfile, data and sample URL. If you can describe the data contents maybe I can fashion a similar dataset or perhaps there's already a suitable candidate in the regression tests suite.

Steve


From: deduikertjes [notifications@github.com]
Sent: Thursday, November 13, 2014 1:24 AM
To: mapserver/mapserver
Cc: Lime, Steve D (MNIT)
Subject: Re: [mapserver] WMS-dimensions on 6.5-dev not working properly (#5032)

Hi Steve,

I'm happy to provide a test case.

What would you like to have? Mapfile + data? Or only an URL from a service.
I prefer to make this test case non public (data is not mine). So maybe
we can discuss this further on PM?

MArco

On 12-11-14 17:13, Steve Lime wrote:

Got it. @deduikertjes https://github.com/deduikertjes, any chance
you have a small test case available?

Steve


Reply to this email directly or view it on GitHub
#5032 (comment).


Reply to this email directly or view it on GitHubhttps://github.com//issues/5032#issuecomment-62851382.

sdlime added a commit that referenced this issue Nov 26, 2014
… a MapServer expression only...
@sdlime
Copy link
Member

@sdlime sdlime commented Nov 26, 2014

@deduikertjes, I just patched master. Can you give it a try?

Steve

BTW Thanks for the test case!

@sdlime
Copy link
Member

@sdlime sdlime commented Dec 1, 2014

It was obvious what the problem was so I'm confident the issue has been fixed. Closing for now...

@sdlime sdlime closed this Dec 1, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.