MapServer WCS GetCapabilites request doesn't return list of all versions supported #5046

Closed
nmtoken opened this Issue Dec 8, 2014 · 3 comments

Comments

Projects
None yet
3 participants
@nmtoken

nmtoken commented Dec 8, 2014

I'm looking at WCS 2.0.1 support in MapServer version 6.4.1.

I've noticed that a GetCapabilities request doesn't return all the versions of WCS supported by the server.

GetCapabilities with acceptversions=2.0.1 reports only 2.0.1 support

GetCapabilities with no versions reports only 2.0.1 support

GetCapabilities with version=1.1.0 reports only 1.1.0 support

This appears to be a bug

@sdlime

This comment has been minimized.

Show comment
Hide comment
@sdlime

sdlime Dec 18, 2014

Member

@Schpidi, is this something you can look at or should I? --Steve

Member

sdlime commented Dec 18, 2014

@Schpidi, is this something you can look at or should I? --Steve

@Schpidi

This comment has been minimized.

Show comment
Hide comment
@Schpidi

Schpidi Dec 23, 2014

Member

This actually looks like an omission. I'll see if I find some spare time...

Member

Schpidi commented Dec 23, 2014

This actually looks like an omission. I'll see if I find some spare time...

Schpidi added a commit to mapserver/msautotest_DEPRECATED that referenced this issue Jan 6, 2015

@Schpidi Schpidi closed this in bf27d13 Jan 6, 2015

@Schpidi

This comment has been minimized.

Show comment
Hide comment
@Schpidi

Schpidi Jan 6, 2015

Member

Should be corrected for WCS now. I guess this also applies to WFS and probably other OGC services? @rouault, what do you think about WFS?

Member

Schpidi commented Jan 6, 2015

Should be corrected for WCS now. I guess this also applies to WFS and probably other OGC services? @rouault, what do you think about WFS?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment