New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix builds with Visual Studio 2013 #5059

Closed
szekerest opened this Issue Jan 18, 2015 · 4 comments

Comments

Projects
None yet
2 participants
@szekerest
Member

szekerest commented Jan 18, 2015

When building mapserver with VS2013, the following errors:

..renderers/agg/include/agg_conv_clipper.h(72): error C2039: 'max' : is not a member of 'std'

Due to a breaking change in VS2003, you must use #include when you call std::min() or std::max()

For more information refer to the STL section of the following document:
http://msdn.microsoft.com/en-us/library/vstudio/bb531344%28v=vs.120%29.aspx

@szekerest szekerest self-assigned this Jan 18, 2015

@szekerest szekerest added this to the 6.4.2 release milestone Jan 18, 2015

@jmckenna

This comment has been minimized.

Show comment
Hide comment
@jmckenna

jmckenna Jan 18, 2015

Member

I believe all of the work now should go to making sure Visual Sudio 2014 is supported in our MapServer environments. Dane Springmeyer has recently done a lot of work to make sure of this, for Mapnik and Mapbox:

Member

jmckenna commented Jan 18, 2015

I believe all of the work now should go to making sure Visual Sudio 2014 is supported in our MapServer environments. Dane Springmeyer has recently done a lot of work to make sure of this, for Mapnik and Mapbox:

@jmckenna

This comment has been minimized.

Show comment
Hide comment
@jmckenna

jmckenna Jan 18, 2015

Member

..which I believe is now referred to as "Visual Studio 2015 preview"

Member

jmckenna commented Jan 18, 2015

..which I believe is now referred to as "Visual Studio 2015 preview"

@szekerest

This comment has been minimized.

Show comment
Hide comment
@szekerest

szekerest Jan 18, 2015

Member

I prefer to work with release versions only.
Once VS2015 is released, I'm going to switch my builds to that version shortly.

Member

szekerest commented Jan 18, 2015

I prefer to work with release versions only.
Once VS2015 is released, I'm going to switch my builds to that version shortly.

@jmckenna

This comment has been minimized.

Show comment
Hide comment
@jmckenna

jmckenna Jan 18, 2015

Member

ok. I will also upgrade my builds to 2013 now. Thanks.

Member

jmckenna commented Jan 18, 2015

ok. I will also upgrade my builds to 2013 now. Thanks.

@szekerest szekerest closed this Jan 31, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment