New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Empty value trigger segfault in label with LABELCACHE OFF #5241

Closed
yjacolin opened this Issue Feb 15, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@yjacolin
Contributor

yjacolin commented Feb 15, 2016

Here is a minimalist mapfile from wxs msautotest:

MAP

NAME WMS_TEST
SHAPEPATH ./data
FONTSET etc/fonts.txt

WEB
  METADATA
    "wms_onlineresource"   "http://localhost/path/to/ows?"
    "ows_enable_request" "DescribeLayer" 
    "wms_enable_request" "!GetCapabilities !GetFeatureInfo GetMap"
  END
END

PROJECTION
  "init=epsg:4326"
END

LAYER
  NAME lakes_elev

  METADATA
    "DESCRIPTION" "Lakes with dimesions (elevation and text)"
     "wms_title"         "Lakes"
    "wms_description"   "Lakes"
    "wms_enable_request" "*"
  END
  TYPE POLYGON
  STATUS ON
  DATA lakes2
   PROJECTION
    "init=epsg:4326"
  END
  LABELITEM "text_dimen"
  LABELCACHE OFF # <---- needed to triger the issue
  CLASS
    NAME "Lakes with elevation"
    STYLE
      COLOR 0 0 240
      OUTLINECOLOR 0 0 199    
    END
    LABEL
      COLOR 0 0 0
      OUTLINECOLOR 255 255 255
      FONT "vera"
      TYPE truetype
      SIZE 8
      POSITION cc
        STYLE
          COLOR 255 0 0
        END
    END #end label
  END
END # layer

END

/!\ you need the lakes2.shp with an empty value in text_dimen as the problem come from LABELCACHE OFF with an empty value in the column.

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Feb 15, 2016

Member

@yjacolin please send me your lakes2 dataset privately

Member

tbonfort commented Feb 15, 2016

@yjacolin please send me your lakes2 dataset privately

@tbonfort tbonfort closed this in 9ade01a Feb 15, 2016

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Feb 15, 2016

Member

Fixed in 9ade01a

Member

tbonfort commented Feb 15, 2016

Fixed in 9ade01a

@yjacolin

This comment has been minimized.

Show comment
Hide comment
@yjacolin

yjacolin Feb 15, 2016

Contributor

thanks, this is fixed indeed.

Contributor

yjacolin commented Feb 15, 2016

thanks, this is fixed indeed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment