New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash on layer TYPE POLYGON with LABELCACHE OFF #4837

Merged
merged 1 commit into from Jan 9, 2014

Conversation

Projects
None yet
2 participants
@tbonfort
Member

tbonfort commented Jan 8, 2014

I built MapServer from master yesterday (Jan. 7, 2014) and today I encountered a crash when I turned off the label cache on a polygon layer. Line layers also seem problematic, but points are fine.

Sample mapfile: https://www.dropbox.com/s/yqzqx1gqwiq8rww/labelcache.map

Backtrace: https://www.dropbox.com/s/ds6uj9yn7gp2qim/backtrace.txt

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Jan 8, 2014

Member

could you provide the backtrace with debug symbols turned on please (cmake .. -DCMAKE_BUILD_TYPE=Debug)

Member

tbonfort commented Jan 8, 2014

could you provide the backtrace with debug symbols turned on please (cmake .. -DCMAKE_BUILD_TYPE=Debug)

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Jan 8, 2014

Member

hmm, you don't have a fontset or font defined, so there's not much mapserver can do here. Definitely shouldn't crash though. Forget the debug backtrace, I hadn't seen your mapfile was self contained.

Member

tbonfort commented Jan 8, 2014

hmm, you don't have a fontset or font defined, so there's not much mapserver can do here. Definitely shouldn't crash though. Forget the debug backtrace, I hadn't seen your mapfile was self contained.

@cnieman

This comment has been minimized.

Show comment
Hide comment
@cnieman

cnieman Jan 8, 2014

Contributor

It works without a font as a point layer type. I thought there was a built-in default font now?

Contributor

cnieman commented Jan 8, 2014

It works without a font as a point layer type. I thought there was a built-in default font now?

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Jan 8, 2014

Member

You're right, I forgot you were using master

Member

tbonfort commented Jan 8, 2014

You're right, I forgot you were using master

tbonfort added a commit to tbonfort/mapserver that referenced this pull request Jan 8, 2014

@ghost ghost assigned tbonfort Jan 8, 2014

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Jan 8, 2014

Member

@cnieman please check the proposed fix

Member

tbonfort commented Jan 8, 2014

@cnieman please check the proposed fix

@cnieman

This comment has been minimized.

Show comment
Hide comment
@cnieman

cnieman Jan 8, 2014

Contributor

Looks good to me. Thanks!

Contributor

cnieman commented Jan 8, 2014

Looks good to me. Thanks!

tbonfort added a commit to mapserver/msautotest_DEPRECATED that referenced this pull request Jan 9, 2014

tbonfort added a commit to tbonfort/mapserver that referenced this pull request Jan 9, 2014

tbonfort added a commit to mapserver/msautotest_DEPRECATED that referenced this pull request Jan 9, 2014

@tbonfort tbonfort merged commit e52b4b5 into mapserver:master Jan 9, 2014

1 check was pending

default The Travis CI build is in progress
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment