New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Legend MapServer 7.0.1 Label SIZE is ignored when using SIZEUNITS meters #5268

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants
@tbonfort
Member

tbonfort commented Aug 27, 2016

When you use SIZEUNITS meters instead of pixel in your LAYER the SIZE of your LEGEND is very small as long as you define only size. When you define MINSIZE and MAXSIZE the size is ok.

LEGEND
    STATUS ON
    KEYSIZE 30 30
    KEYSPACING 5 3  
    LABEL
        TYPE TRUETYPE
        FONT 'arial' 
        SIZE 10
        COLOR 119 179 0
    END 
END
  • example using SIZE 10
    legend_mapserv7_size10
  • Example using SIZE 100 (legend comes back with a big white extra area at the left and bottom)
    legend_mapserv7_size100
  • when you add MINSIZE and MAXSIZE the Legend SIZE is ok
LEGEND
    STATUS ON
    KEYSIZE 30 30
    KEYSPACING 5 3  
    LABEL
        TYPE TRUETYPE
        FONT 'arial' 
        SIZE 10
                MINSIZE 10
                MAXSIZE 10
        COLOR 119 179 0
    END 
END

legend_mapserv_7_size_minsize_maxsize

tbonfort added a commit to tbonfort/mapserver that referenced this pull request Aug 27, 2016

@jmckenna

This comment has been minimized.

Show comment
Hide comment
@jmckenna

jmckenna Sep 15, 2016

Member

@astroidex can you confirm that thomas' fix posted here, works in your case?

Member

jmckenna commented Sep 15, 2016

@astroidex can you confirm that thomas' fix posted here, works in your case?

@jmckenna

This comment has been minimized.

Show comment
Hide comment
@jmckenna

jmckenna Sep 19, 2016

Member

@astroidex can you confirm that thomas' fix posted here, works in your case? Or, can you post the sample mapfile + data, so I can test?

Member

jmckenna commented Sep 19, 2016

@astroidex can you confirm that thomas' fix posted here, works in your case? Or, can you post the sample mapfile + data, so I can test?

@jmckenna

This comment has been minimized.

Show comment
Hide comment
@jmckenna

jmckenna Sep 20, 2016

Member

@astroidex can you confirm that thomas' fix posted here, works in your case? Or, can you post the sample mapfile + data, so I can test? (I'd like to get this included in the MapServer 7.0.2 release this week)

Member

jmckenna commented Sep 20, 2016

@astroidex can you confirm that thomas' fix posted here, works in your case? Or, can you post the sample mapfile + data, so I can test? (I'd like to get this included in the MapServer 7.0.2 release this week)

@tbonfort

This comment has been minimized.

Show comment
Hide comment
@tbonfort

tbonfort Sep 21, 2016

Member

applied to branch-7-0

Member

tbonfort commented Sep 21, 2016

applied to branch-7-0

@tbonfort tbonfort closed this Sep 21, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment