Skip to content
This repository

A Ruby client for Things' Applescript API.

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 lib
Octocat-spinner-32 spec
Octocat-spinner-32 .document
Octocat-spinner-32 .gitignore
Octocat-spinner-32 LICENSE
Octocat-spinner-32 README.textile
Octocat-spinner-32 Rakefile
Octocat-spinner-32 VERSION
Octocat-spinner-32 things-client.gemspec
README.textile

things-client is a ruby-base client for API of the popular GTD app Things, available on the Mac.

Requirements

To use things-client you need Things which is version 1.2.0 or greater.

Installation

The gem is hosted on Gemcutter. To install it, use the following command:

sudo gem install things-client --source http://gemcutter.org

To get the latest version, clone the gem from github and run rake install:

git clone http://github.com/marcinbunsch/things-client
cd things-client
rake check_dependencies:runtime
sudo rake install

Usage

Before using this gem you must require it by calling:

require 'things'

From then on you can manipulate Todos, Projects, Areas, Tags, People and Lists, like this:

todo = Things::Todo.create(:name => 'Take out the garbage')
todo.name = 'Take out the garbage and old boxes'  
todo.save

For more information, see the wiki at http://wiki.github.com/marcinbunsch/things-client/

Contribution

You’re more than welcome to fork and improve this gem. Usual rules:

  • Fork the project.
  • Make your feature addition or bug fix.
  • Add tests for it. This is important so I don’t break it in a
    future version unintentionally.
  • Commit, do not mess with rakefile, version, or history.
    (if you want to have your own version, that is fine but
    bump version in a commit by itself I can ignore when I pull)
  • Send me a pull request.

Copyright

Copyright © 2010 Marcin Bunsch. See LICENSE for details.

Something went wrong with that request. Please try again.