Update the Guard version #17

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants

I updated the guard dependency to use the latest version, as it kept using ~>1.0, which makes it very hard to use other gems using guard (today most gems use >= 2.x)

@heartcode heartcode referenced this pull request Oct 7, 2013

Closed

Update Guard dependency #16

Owner

marcisme commented Oct 8, 2013

I fixed the fakefs issue, but when I update guard I'm getting both AT failures and manually reproducible failures. I'm looking into it, but I'm on vacation right now, so it may be a couple days.

It's great you've made progress, thanks a lot! Don't worry about the code now, enjoy your holiday :)

marcisme added a commit that referenced this pull request Oct 9, 2013

upgrade to guard 2.x
This should address PR #17.

* remove explicit rb-fsevent dep, as guard now depends on this
* prepend Guardfile with ignore! statement to not ignore tmp dirs
* wait for guard to start more graciously
* convert to Guard::Plugin
* update tests to account for :watchers being an option now
Owner

marcisme commented Oct 9, 2013

I still have some cleanup to do to remove older versions of ruby that guard no longer supports, but this should work now.

Give it a try, and let me know if it works for you.

Owner

marcisme commented Oct 10, 2013

I just released 0.5.0, which uses Guard 2.x.

@marcisme marcisme closed this Oct 10, 2013

Great news, thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment