Permalink
Browse files

Added Jewelry rake tasks to easily manage gem releases

  • Loading branch information...
1 parent 4a9034b commit eae46c489464d7a51a1843fe8f09de1d07bdb46c Marco Campana committed Oct 18, 2009
Showing with 48 additions and 27 deletions.
  1. +1 −2 .gitignore
  2. +14 −0 Rakefile
  3. +33 −25 git-notifier.gemspec
View
@@ -1,2 +1 @@
-pids/*
-*.gem
+pkg/
View
@@ -0,0 +1,14 @@
+begin
+ require 'jeweler'
+ Jeweler::Tasks.new do |gemspec|
+ gemspec.name = "git-notifier"
+ gemspec.summary = "Watch one or more git repositories and receive a growl notification when a change is committed"
+ gemspec.description = "git-notifier is a gem for Mac Os that allows you to watch one or more git repositories and receive a growl notification when a change is committed"
+ gemspec.email = "m.campana@gmail.com"
+ gemspec.homepage = "http://github.com/marcocampana/git-notifier"
+ gemspec.authors = ["Marco Campana"]
+ end
+ Jeweler::GemcutterTasks.new
+rescue LoadError
+ puts "Jeweler not available. Install it with: sudo gem install technicalpickles-jeweler -s http://gems.github.com"
+end
View
@@ -1,36 +1,44 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE
+# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{git-notifier}
- s.version = "0.2"
+ s.version = "0.2.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Marco Campana"]
- s.date = %q{2009-10-13}
- s.description = %q{ git-notifier is a gem for Mac Os that allows you to watch one or more git repositories and receive a growl notification when a change is committed}
+ s.date = %q{2009-10-18}
+ s.default_executable = %q{git-notifier}
+ s.description = %q{git-notifier is a gem for Mac Os that allows you to watch one or more git repositories and receive a growl notification when a change is committed}
s.email = %q{m.campana@gmail.com}
s.executables = ["git-notifier"]
+ s.extra_rdoc_files = [
+ "README.rdoc"
+ ]
+ s.files = [
+ ".gitignore",
+ "History.txt",
+ "README.rdoc",
+ "Rakefile",
+ "VERSION",
+ "bin/git-notifier",
+ "git-notifier.gemspec"
+ ]
s.homepage = %q{http://github.com/marcocampana/git-notifier}
- # s.has_rdoc = false
- # s.rdoc_options = ["--inline-source", "--charset=UTF-8"]
- # s.require_paths = ["lib"]
- s.rubyforge_project = %q{git-notifier}
- s.rubygems_version = %q{1.3.1}
- s.summary = %q{ git-notifier is a gem for Mac Os that allows you to watch one or more git repositories and receive a growl notification when a change is committed }
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = %q{1.3.3}
+ s.summary = %q{Watch one or more git repositories and receive a growl notification when a change is committed}
- # if s.respond_to? :specification_version then
- # current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- # s.specification_version = 2
- #
- # if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- # s.add_runtime_dependency(%q<mime-types>, [">= 1.15"])
- # s.add_runtime_dependency(%q<diff-lcs>, [">= 1.1.2"])
- # else
- # s.add_dependency(%q<mime-types>, [">= 1.15"])
- # s.add_dependency(%q<diff-lcs>, [">= 1.1.2"])
- # end
- # else
- # s.add_dependency(%q<mime-types>, [">= 1.15"])
- # s.add_dependency(%q<diff-lcs>, [">= 1.1.2"])
- # end
-end
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ else
+ end
+ else
+ end
+end

0 comments on commit eae46c4

Please sign in to comment.