Upgrade to latest std #6

Merged
merged 3 commits into from Dec 19, 2011

Conversation

Projects
None yet
2 participants
Contributor

philips commented Dec 19, 2011

This is a follow on to my first pull request that upgrades to the latest version of std, it seems to work.

philips added some commits Dec 19, 2011

package.json: add std to dependencies
if you add kafka as a dependency to a project it doesn't work because
std is missing, if you install the latest std it doesn't work because
_init is now init via std commit 02e278b0.

Start by fixing up the dependency in the package.json.
lib: upgrade to latest std version
_init is now init in std thanks to 02e278b0. update all of the usages.
node_modules: stop including std
including std in node_modules is no longer needed since it is installed
via package.json, remove it.

marcuswestin added a commit that referenced this pull request Dec 19, 2011

@marcuswestin marcuswestin merged commit 60a690e into marcuswestin:master Dec 19, 2011

Owner

marcuswestin commented Dec 19, 2011

Great stuff - thanks man!

Owner

marcuswestin commented Dec 19, 2011

just pushed latest std v0.1.28 and kafka v0.2.1 to the npm repo.

Thanks again for taking the time to fix this!

Enough people seem to be using the lib that it may be time to get unit tests going to avoid breakage.

Contributor

philips commented Dec 19, 2011

Thanks for merging these so quickly. Looking forward to playing around with node-kafka.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment