Permalink
Browse files

Merge branch 'master' into pvr-ppa

  • Loading branch information...
2 parents e686e63 + 8ce8010 commit ab82e455d479804577945d84e5bf345c2e5f4e33 Lars Op den Kamp committed Apr 10, 2011
Showing 3,998 changed files with 2,148 additions and 1,413,097 deletions.
The diff you're trying to view is too large. We only load the first 3000 changed files.
View
@@ -312,6 +312,9 @@ lib/cmyth/Makefile
# /project/Win32BuildSetup/dependencies
/project/Win32BuildSetup/dependencies/SDL.dll
/project/Win32BuildSetup/dependencies/glew32.dll
+/project/Win32BuildSetup/dependencies/pcre.dll
+/project/Win32BuildSetup/dependencies/pcrecpp.dll
+/project/Win32BuildSetup/dependencies/python26.dll
# /project/Win32BuildSetup/
/project/Win32BuildSetup/BuildLog.htm
@@ -368,9 +371,14 @@ lib/cmyth/Makefile
/system/libssl32.dll
/system/hdhomerun.dll
/system/ssh.dll
+/system/sqlite3.dll
+/system/libsamplerate-0.dll
# /system/cdrip
/system/cdrip/lame_enc.dll
+/system/cdrip/ogg.dll
+/system/cdrip/vorbis.dll
+/system/cdrip/vorbisenc.dll
# /system/players/dvdplayer
/system/players/dvdplayer/avcodec-52.dll
@@ -410,15 +418,7 @@ lib/cmyth/Makefile
/system/profiles.xml
# /system/python
-/system/python/Lib/
-/system/python/python24.zip
-/system/python/python24.dll
-/system/python/DLLs/_socket.pyd
-/system/python/DLLs/pyexpat.pyd
-/system/python/DLLs/select.pyd
-/system/python/DLLs/unicodedata.pyd
-/system/python/DLLs/zlib.pyd
-/system/python/DLLs/bz2.pyd
+/system/python/
# /system/webserver
/system/webserver
@@ -1055,6 +1055,8 @@ lib/cmyth/Makefile
# /xbmc/interfaces/
/xbmc/interfaces/Makefile
+/xbmc/interfaces/python/Makefile
+/xbmc/interfaces/python/xbmcmodule/Makefile
/xbmc/interfaces/python/linux/Makefile
/xbmc/interfaces/python/linux/wrapper_python.def
View
@@ -129,7 +129,6 @@ LIB_DIRS=\
lib/libhdhomerun \
lib/libid3tag \
lib/libapetag \
- xbmc/interfaces/python/linux \
lib/cpluff \
lib/xbmc-dll-symbols \
lib/jsoncpp/src/lib_json
@@ -183,9 +182,6 @@ CLEAN_FILES=xbmc.bin xbmc-xrandr
DISTCLEAN_FILES=config.h config.log config.status tools/Linux/xbmc.sh \
tools/Linux/xbmc-standalone.sh autom4te.cache config.h.in~ \
- lib/python/Include/pyconfig.h \
- lib/python/configure.lineno \
- lib/python/libpython2.4.so.1.0 \
system/libcpluff-@ARCH@.so
all : Makefile externals xbmc.bin xbmc-xrandr skins
@@ -454,8 +450,6 @@ libaddon: exports
libpython: dllloader
$(MAKE) -C xbmc/interfaces/python
$(MAKE) -C xbmc/interfaces/python/xbmcmodule
-python: dllloader
- $(MAKE) -C xbmc/interfaces/python/linux
dvdpcodecs: dllloader
$(MAKE) -C lib
$(MAKE) -C lib/libdvd
@@ -497,8 +491,8 @@ imagelib: dllloader
$(MAKE) -C lib/cximage-6.0
codecs: papcodecs dvdpcodecs
-libs: cmyth libhdhomerun libid3tag imagelib libexif python system/libcpluff-@ARCH@.so
-externals: libaddon codecs libs python pvrclients visualizations screensavers
+libs: cmyth libhdhomerun libid3tag imagelib libexif system/libcpluff-@ARCH@.so
+externals: libaddon codecs libs pvrclients visualizations screensavers
xcode_depends: \
codecs libs python pvrclients visualizations screensavers eventclients skins \
@@ -628,10 +622,7 @@ DYNOBJSXBMC= \
xbmc/pvr/windows/pvrwindows.a \
xbmc/guilib/guilib.a # must be dynamic to avoid linker errors
-ifeq ($(findstring arm,@ARCH@), arm)
-# Force external python2.6 for now!
-LIBS +=-lpython2.6
-endif
+LIBS += @PYTHON_LDFLAGS@
xbmc.bin: $(OBJSXBMC) $(DYNOBJSXBMC)
ifeq ($(findstring osx,@ARCH@), osx)
@@ -681,17 +672,15 @@ endif
install-arch:
@# Arch dependent files
ifeq ($(findstring freebsd,@ARCH@), freebsd)
- @find -E system addons -type f -not -iregex ".*svn.*|.*script\.module\..*" \
- -iregex ".*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs|.*python.*\.zip" \
+ @find -E system addons -type f -not -iregex ".*svn.*" \
+ -iregex ".*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs" \
-exec sh -c "install -d \"$(DESTDIR)$(libdir)/xbmc/\`dirname '{}'\`\"" \; \
-and \
-exec install "{}" $(DESTDIR)$(libdir)/xbmc/"{}" \; \
-exec printf " -- %-75.75s\r" "{}" \;
else
- @find system addons -regextype posix-extended -type f -not -iregex ".*svn.*|.*script\.module\..*" -iregex ".*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs|.*python.*\.zip" -exec install -D "{}" $(DESTDIR)$(libdir)/xbmc/"{}" \; -printf " -- %-75.75f\r"
+ @find system addons -regextype posix-extended -type f -not -iregex ".*svn.*" -iregex ".*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs" -exec install -D "{}" $(DESTDIR)$(libdir)/xbmc/"{}" \; -printf " -- %-75.75f\r"
endif
- @cp -r addons/script.module.pil $(DESTDIR)$(libdir)/xbmc/addons/
- @cp -r addons/script.module.pysqlite $(DESTDIR)$(libdir)/xbmc/addons/
install-scripts:
@install -d $(DESTDIR)$(bindir)
@@ -713,13 +702,14 @@ install-datas: install-scripts
@# Arch independent files
ifeq ($(findstring bsd,@ARCH@), bsd)
@find -E addons language media sounds userdata system -type f \
- -not -iregex ".*script\.module\..*|.*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs|.*svn.*|.*\.so|.*\.dll|.*\.pyd|.*python.*\.zip" \
+ -not -iregex ".*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs|.*svn.*|.*\.so|.*\.dll" \
+ -not -iregex ".*@ARCH@.*|.*\.vis|.*\.xbs|.*svn.*|.*\.so|.*\.dll" \
-exec sh -c "install -d \"$(DESTDIR)$(datarootdir)/xbmc/\`dirname '{}'\`\"" \; \
-and \
-exec install -m 0644 "{}" $(DESTDIR)$(datarootdir)/xbmc/"{}" \; \
-exec printf " -- %-75.75s\r" "{}" \;
else
- @find addons language media sounds userdata system -regextype posix-extended -type f -not -iregex ".*script\.module\..*|.*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs|.*svn.*|.*\.so|.*\.dll|.*\.pyd|.*python.*\.zip" -exec install -D -m 0644 "{}" $(DESTDIR)$(datarootdir)/xbmc/"{}" \; -printf " -- %-75.75f\r"
+ @find addons language media sounds userdata system -regextype posix-extended -type f -not -iregex ".*@ARCH@.*|.*\.pvr|.*\.vis|.*\.xbs|.*svn.*|.*\.so|.*\.dll" -exec install -D -m 0644 "{}" $(DESTDIR)$(datarootdir)/xbmc/"{}" \; -printf " -- %-75.75f\r"
endif
@# Icons and links
@install -d $(DESTDIR)$(datarootdir)/applications
View
@@ -53,7 +53,7 @@ Build-Depends: debhelper (>= 7.0.50~), python-support, cmake,
libwavpack-dev, python-dev, gawk, gperf, nasm [!amd64], libcwiid1-dev,
libbluetooth-dev, zlib1g-dev, libsmbclient-dev,
libiso9660-dev, libssl-dev, lsb-release, libvdpau-dev, libmicrohttpd-dev,
- libmodplug-dev, librtmp-dev, libcrystalhd-dev, curl
+ libmodplug-dev, librtmp-dev, libcrystalhd-dev, curl, python-dev
*** For developers and anyone else who compiles frequently it is recommended to
use ccache
@@ -94,11 +94,7 @@ Tip: by adding -j<number> to the make command, you describe how many
$ make -j2
-.3 $ make -C lib/addons/script.module.pil
-
-.4 $ make -C lib/addons/script.module.pysqlite
-
-.5 $ make install
+.3 $ make install
This will install XBMC in the prefix provided in 4.1 as well as a launcher script.
View
@@ -44,7 +44,7 @@ Two methods exist to install the required Ubuntu packages:
For Ubuntu (all versions >= 7.04):
- # sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libenca-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmpeg3-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs
+ # sudo apt-get install subversion make g++ gcc gawk pmount libtool nasm yasm automake cmake gperf zip unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-gnutls-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libenca-dev libxt-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmpeg3-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libssh-dev gettext cvs python-dev
For Ubuntu Maverick (10.10):
# sudo apt-get install autopoint
Oops, something went wrong.

0 comments on commit ab82e45

Please sign in to comment.