Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Drizzle database bindings for Node.js
C++ JavaScript
Failed to load latest commit information.
lib Fixing issue where NODE_PSYMBOL throws compilation errors on node <= …
src Allowing db-drizzle to be used in node 0.4.x and 0.5.x
.gitignore Updating options processing since they are now moved to driver
.gitmodules
.npmignore
CHANGELOG Fixing issue where NODE_PSYMBOL throws compilation errors on node <= …
README.md Updating node-db
db-drizzle.js
package.json Fixing issue where NODE_PSYMBOL throws compilation errors on node <= …
tests-settings.json Fixing issue with test-settings.json
tests.js
wscript

README.md

db-drizzle: Drizzle database bindings for Node.js

For detailed information about this and other Node.js database bindings visit the Node.js DB homepage.

INSTALL

Before proceeding with installation, you need to have the Drizzle libraries and include files. In order for the installation script to locate them properly, you'll need to set the DRIZZLE_INCLUDE_DIR and DRIZZLE_LIB_DIR environment variables. For example:

$ export DRIZZLE_INCLUDE_DIR=/usr/include/libdrizzle
$ export DRIZZLE_LIB_DIR=/usr/lib

Once the environment variables are set, install with npm:

$ npm install db-drizzle

QUICK START

var drizzle = require('db-drizzle');
new drizzle.Database({
    hostname: 'localhost',
    user: 'root',
    password: 'password',
    database: 'node'
}).connect(function(error) {
    if (error) {
        return console.log("CONNECTION ERROR: " + error);
    }

    this.query().select('*').from('users').execute(function(error, rows) {
        if (error) {
            return console.log('ERROR: ' + error);
        }
        console.log(rows.length + ' ROWS');
    });
});

LICENSE

This module is released under the MIT License.

Something went wrong with that request. Please try again.