Popup option missing from default usage and panning problem #4

Closed
Toutouwai opened this Issue Mar 15, 2012 · 5 comments

Comments

Projects
None yet
3 participants
@Toutouwai

The "popup" option for having a marker's info window open by default is only available on the addMarker additional method. It would be nice to have it available via the default usage. Either that or add "address" as an option on the addMarker method.

Also, when popup is set to true, it doesn't pan the map as it should - it seems to not pan down far enough meaning that the top of the info window can be cut off. Compare the panning that occurs when an info window is opened by click versus open using popup: true.

@marioestrada

This comment has been minimized.

Show comment
Hide comment
@marioestrada

marioestrada Mar 15, 2012

Owner

Thanks, I'll look into it when I have the time.

Owner

marioestrada commented Mar 15, 2012

Thanks, I'll look into it when I have the time.

@wjbryant

This comment has been minimized.

Show comment
Hide comment
@wjbryant

wjbryant May 14, 2012

The missing popup option was confusing to me as well. Adding marker.popup to the array of arguments on lines 196 and 202 should fix this.

Also, changing line 168

popup && infowindow.open($gmap, gmarker);

to

if (popup) {
    google.maps.event.addListenerOnce($gmap, 'tilesloaded', function () {
        infowindow.open($gmap, gmarker);
    });
}

seems to help with the info window auto-panning problem.

The missing popup option was confusing to me as well. Adding marker.popup to the array of arguments on lines 196 and 202 should fix this.

Also, changing line 168

popup && infowindow.open($gmap, gmarker);

to

if (popup) {
    google.maps.event.addListenerOnce($gmap, 'tilesloaded', function () {
        infowindow.open($gmap, gmarker);
    });
}

seems to help with the info window auto-panning problem.

@marioestrada

This comment has been minimized.

Show comment
Hide comment
@marioestrada

marioestrada May 14, 2012

Owner
@wjbryant

This comment has been minimized.

Show comment
Hide comment
@wjbryant

wjbryant May 14, 2012

That fixed it for me. Thanks!

That fixed it for me. Thanks!

@marioestrada

This comment has been minimized.

Show comment
Hide comment
@marioestrada

marioestrada May 14, 2012

Owner

Fixed in 2.1.2

Owner

marioestrada commented May 14, 2012

Fixed in 2.1.2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment