Permalink
Browse files

Depend on require_relative 1.0.2, it has no effect on 1.9.x. Safest b…

…et possible.
  • Loading branch information...
michaelklishin committed Jun 18, 2011
1 parent 119f533 commit 40889026245e923be35948b372769743cefe7c83
Showing with 2 additions and 2 deletions.
  1. +1 −1 Rakefile
  2. +1 −1 linecache.gemspec
View
@@ -80,7 +80,7 @@ EOF
spec.files = FILES.to_a
spec.extensions = ["ext/extconf.rb"]
- spec.add_dependency "require_relative"
+ spec.add_dependency "require_relative", ">= 1.0.2"
spec.required_ruby_version = '>= 1.8.2'
spec.date = Time.now
View
@@ -47,7 +47,7 @@ example in a debugger where the same lines are shown many times.
]
s.extensions << "ext/trace_nums/extconf.rb"
s.add_dependency("ruby_core_source", ">= 0.1.4")
- s.add_dependency "require_relative"
+ s.add_dependency "require_relative, ">= 1.0.2""
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION

0 comments on commit 4088902

Please sign in to comment.