Permalink
Browse files

Merge branch 'feature/adding-gemfile-gems-to-gemspec' of https://gith…

…ub.com/krainboltgreene/configatron into krainboltgreene-feature/adding-gemfile-gems-to-gemspec

Conflicts:
	configatron.gemspec
  • Loading branch information...
2 parents c07d263 + be843ea commit f2245e953b9c3f53d7400af0668a0f7758e58cf8 @markbates committed Apr 16, 2012
Showing with 43 additions and 41 deletions.
  1. +3 −5 Gemfile
  2. +21 −13 Gemfile.lock
  3. +16 −23 Rakefile
  4. +3 −0 configatron.gemspec
View
@@ -1,6 +1,4 @@
-source 'http://rubygems.org'
+source 'https://rubygems.org'
-gem 'rake'
-gem "rspec", ">= 2.6.0"
-gem 'gemstub', ">= 2.0.0"
-gem 'yamler'
+# Specify your gem's dependencies in bar.gemspec
+gemspec
View
@@ -1,7 +1,14 @@
+PATH
+ remote: .
+ specs:
+ configatron (2.9.0)
+ yamler (>= 0.1.0)
+
GEM
- remote: http://rubygems.org/
+ remote: https://rubygems.org/
specs:
- activesupport (3.1.3)
+ activesupport (3.2.2)
+ i18n (~> 0.6)
multi_json (~> 1.0)
diff-lcs (1.1.3)
erubis (2.7.0)
@@ -13,25 +20,26 @@ GEM
genosaurus (1.2.4)
erubis
hashie (1.2.0)
+ i18n (0.6.0)
mark_facets (0.2.0)
hashie
- multi_json (1.0.4)
+ multi_json (1.2.0)
rake (0.9.2.2)
- rspec (2.7.0)
- rspec-core (~> 2.7.0)
- rspec-expectations (~> 2.7.0)
- rspec-mocks (~> 2.7.0)
- rspec-core (2.7.1)
- rspec-expectations (2.7.0)
+ rspec (2.8.0)
+ rspec-core (~> 2.8.0)
+ rspec-expectations (~> 2.8.0)
+ rspec-mocks (~> 2.8.0)
+ rspec-core (2.8.0)
+ rspec-expectations (2.8.0)
diff-lcs (~> 1.1.2)
- rspec-mocks (2.7.0)
+ rspec-mocks (2.8.0)
yamler (0.1.0)
PLATFORMS
ruby
DEPENDENCIES
- gemstub (>= 2.0.0)
+ configatron!
+ gemstub
rake
- rspec (>= 2.6.0)
- yamler
+ rspec
View
@@ -1,31 +1,24 @@
require 'rubygems'
# Set up gems listed in the Gemfile.
-gemfile = File.expand_path('../Gemfile', __FILE__)
-begin
- ENV['BUNDLE_GEMFILE'] = gemfile
- require 'bundler'
- Bundler.setup
-rescue Bundler::GemNotFound => e
- STDERR.puts e.message
- STDERR.puts "Try running `bundle install`."
- exit!
-end if File.exist?(gemfile)
+ENV['BUNDLE_GEMFILE'] ||= File.expand_path('../Gemfile', __FILE__)
-Bundler.require
+require 'bundler/setup' if File.exists?(ENV['BUNDLE_GEMFILE'])
+
+require 'gemstub'
Gemstub.test_framework = :rspec
-Gemstub.gem_spec do |s|
- s.version = "2.9.0"
- s.summary = "A powerful Ruby configuration system."
- s.rubyforge_project = "magrathea"
- s.add_dependency('yamler', '>=0.1.0')
- s.email = 'mark@markbates.com'
- s.homepage = 'http://www.metabates.com'
- s.files = FileList['lib/**/*.*', 'README.textile', 'LICENSE', 'bin/**/*.*']
-end
+# Gemstub.gem_spec do |s|
+# s.version = "2.9.0"
+# s.summary = "A powerful Ruby configuration system."
+# s.rubyforge_project = "magrathea"
+# s.add_dependency('yamler', '>=0.1.0')
+# s.email = 'mark@markbates.com'
+# s.homepage = 'http://www.metabates.com'
+# s.files = FileList['lib/**/*.*', 'README.textile', 'LICENSE', 'bin/**/*.*']
+# end
-Gemstub.rdoc do |rd|
- rd.title = "Configatron"
-end
+# Gemstub.rdoc do |rd|
+# rd.title = "Configatron"
+# end
View
@@ -19,4 +19,7 @@ Gem::Specification.new do |s|
s.summary = "A powerful Ruby configuration system."
s.add_runtime_dependency "yamler", ">= 0.1.0"
+ s.add_development_dependency 'rake'
+ s.add_development_dependency 'rspec'
+ s.add_development_dependency 'gemstub'
end

0 comments on commit f2245e9

Please sign in to comment.