Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Some key don't compatible with rake #20

Closed
sunteya opened this Issue · 1 comment

3 participants

@sunteya
# Rakefile
gem "configatron", "~> 2.8.2"
require "configatron"

Settings = Configatron.instance
Settings.foo = "foo"
puts Settings.foo  # ok

Settings.import = "import"
puts Settings.import # nothing to print

Because rake is defined some methods in Object: import, task and etc.

@krainboltgreene

I think the solution would be to define your configatron settings outside of the Rakefile, and bring them in via require or something.

The problem is that you're defining something in the Rakefile "space".

@markbates markbates closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.