Skip to content
This repository
Newer
Older
100644 37 lines (32 sloc) 2.364 kb
cc011aa8 »
2010-08-13 Initial Commit
1 # -*- encoding: utf-8 -*-
2
3 Gem::Specification.new do |s|
96bd5f44 »
2011-09-07 Improved coverage percentages.
4 s.name = "cover_me"
5 s.version = "1.2.0.20110907090445"
cc011aa8 »
2010-08-13 Initial Commit
6
506052de »
2011-05-25 Version 1.0.0
7 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
99658a6d »
2011-06-29 Added exclude_file_patterns to configuration to explicity ignore cert…
8 s.authors = ["markbates"]
96bd5f44 »
2011-09-07 Improved coverage percentages.
9 s.date = "2011-09-07"
10 s.description = "CoverMe - Code Coverage for Ruby 1.9"
11 s.email = "mark+cover_me@markbates.com"
99658a6d »
2011-06-29 Added exclude_file_patterns to configuration to explicity ignore cert…
12 s.extra_rdoc_files = ["LICENSE"]
13 s.files = ["lib/cover_me/config.rb", "lib/cover_me/directory_report.rb", "lib/cover_me/emma_formatter.rb", "lib/cover_me/formatter.rb", "lib/cover_me/global_report.rb", "lib/cover_me/hash.rb", "lib/cover_me/html_formatter.rb", "lib/cover_me/index.rb", "lib/cover_me/processor.rb", "lib/cover_me/report.rb", "lib/cover_me/results.rb", "lib/cover_me/templates/emma.xml.erb", "lib/cover_me/templates/index.css", "lib/cover_me/templates/index.html.erb", "lib/cover_me/templates/jquery.js", "lib/cover_me/templates/jquery.tablesorter.js", "lib/cover_me/templates/report.css", "lib/cover_me/templates/report.html.erb", "lib/cover_me.rb", "lib/generators/cover_me/install/install_generator.rb", "lib/generators/cover_me/install/templates/cover_me.rake", "LICENSE"]
96bd5f44 »
2011-09-07 Improved coverage percentages.
14 s.homepage = "http://www.metabates.com"
15 s.post_install_message = "Thank you for installing CoverMe!\n\nUSAGE:\nAt the top of your 'test_helper.rb' or 'spec_helper.rb' place the following:\n\nrequire 'cover_me'\n\n!!! IT IS VERY IMPORTANT THAT THE REQUIRE STATEMENT BE THE VERY FIRST LINE OF THE FILE !!!\n\nRAILS 3:\nIf you are planning on using this with a Rails 3 project please run the following:\n\n$ rails g cover_me:install\n\nThis will install a Rake task to wrap your tests in CoverMe.\n"
99658a6d »
2011-06-29 Added exclude_file_patterns to configuration to explicity ignore cert…
16 s.require_paths = ["lib"]
5a32f56b »
2010-09-30 The first Release Candidate.
17 s.required_ruby_version = Gem::Requirement.new(">= 1.9.2")
96bd5f44 »
2011-09-07 Improved coverage percentages.
18 s.rubyforge_project = "magrathea"
19 s.rubygems_version = "1.8.10"
20 s.summary = "CoverMe - Code Coverage for Ruby 1.9"
cc011aa8 »
2010-08-13 Initial Commit
21
22 if s.respond_to? :specification_version then
23 s.specification_version = 3
24
25 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
26 s.add_runtime_dependency(%q<configatron>, [">= 0"])
27 s.add_runtime_dependency(%q<hashie>, [">= 0"])
28 else
29 s.add_dependency(%q<configatron>, [">= 0"])
30 s.add_dependency(%q<hashie>, [">= 0"])
31 end
32 else
33 s.add_dependency(%q<configatron>, [">= 0"])
34 s.add_dependency(%q<hashie>, [">= 0"])
35 end
36 end
Something went wrong with that request. Please try again.