Update less to chosen version #69

Closed
mgvez opened this Issue Apr 10, 2013 · 10 comments

Comments

Projects
None yet
8 participants
@mgvez

mgvez commented Apr 10, 2013

It would be a great improvement if we could decide the less version that winless uses. As of writing this, the 1.4 version of less is in beta state, so winless only updates to the dev version of 1.3. I need the features of less 1.4 for a project I'm doing, but there's no way I can manually update less to that version, which is is real pain.

@gnomishperson

This comment has been minimized.

Show comment Hide comment
@gnomishperson

gnomishperson May 6, 2013

Within your WinLess install directory, you can download the latest version of less.js and replace the files within the /node_modules/less directory of your WinLess install. WinLess should then grab the correct 1.4 version, you can verify this via the Help -> About menu in the WinLess app.

Within your WinLess install directory, you can download the latest version of less.js and replace the files within the /node_modules/less directory of your WinLess install. WinLess should then grab the correct 1.4 version, you can verify this via the Help -> About menu in the WinLess app.

@marklagendijk

This comment has been minimized.

Show comment Hide comment
@marklagendijk

marklagendijk May 29, 2013

Owner

@gnomishperson thanks for replying to this issue.

Because WinLess includes NPM to update to the latest stable version of LESS, there is an even easier way.

  1. Run cmd as administrator
  2. cd c:\Program Files (x86)\Mark Lagendijk\WinLess
  3. node_modules\.bin\npm install less@beta
  4. Open WinLess and go to Help -> About to verify the result.
Owner

marklagendijk commented May 29, 2013

@gnomishperson thanks for replying to this issue.

Because WinLess includes NPM to update to the latest stable version of LESS, there is an even easier way.

  1. Run cmd as administrator
  2. cd c:\Program Files (x86)\Mark Lagendijk\WinLess
  3. node_modules\.bin\npm install less@beta
  4. Open WinLess and go to Help -> About to verify the result.
@smajl

This comment has been minimized.

Show comment Hide comment
@smajl

smajl Jun 10, 2013

@marklagendijk Thanks for pointing this out. LESS is now 1.4.0 official and WinLess was not updating correctly so I performed manual update (just npm install less in WinLess directory).

smajl commented Jun 10, 2013

@marklagendijk Thanks for pointing this out. LESS is now 1.4.0 official and WinLess was not updating correctly so I performed manual update (just npm install less in WinLess directory).

@magikMaker

This comment has been minimized.

Show comment Hide comment
@magikMaker

magikMaker Jun 27, 2013

Still it would be really great to add an option to settings where it is possible to choose the version. For certain projects it is also necessary to downgrade to a specific version.

@gnomishperson I don't quite understand where to place the less.js file I downloaded from lesscss.org. The folder /node_modules/less contains many, many files.

Still it would be really great to add an option to settings where it is possible to choose the version. For certain projects it is also necessary to downgrade to a specific version.

@gnomishperson I don't quite understand where to place the less.js file I downloaded from lesscss.org. The folder /node_modules/less contains many, many files.

@gnomishperson

This comment has been minimized.

Show comment Hide comment
@gnomishperson

gnomishperson Jun 27, 2013

@magikMaker It's best to include the contents of the whole repo: https://github.com/less/less.js/archive/master.zip which is what that /node_modules/less folder consists of. Or as @marklagendijk noted just use the npm install less method above.

@magikMaker It's best to include the contents of the whole repo: https://github.com/less/less.js/archive/master.zip which is what that /node_modules/less folder consists of. Or as @marklagendijk noted just use the npm install less method above.

@magikMaker

This comment has been minimized.

Show comment Hide comment
@magikMaker

magikMaker Jun 27, 2013

@gnomishperson Excellent! Thank you for a quick reply.

If anyone else is insterested, here's how to install a specific version with npm: https://npmjs.org/doc/install.html

In my case I need the 1.3.0 version: npm install less@1.3.0

worked like a charm! 👍

@gnomishperson Excellent! Thank you for a quick reply.

If anyone else is insterested, here's how to install a specific version with npm: https://npmjs.org/doc/install.html

In my case I need the 1.3.0 version: npm install less@1.3.0

worked like a charm! 👍

@srhise

This comment has been minimized.

Show comment Hide comment
@srhise

srhise Aug 8, 2013

Nice work all. I am now able to switch between versions using this technique.

srhise commented Aug 8, 2013

Nice work all. I am now able to switch between versions using this technique.

@jeepstone

This comment has been minimized.

Show comment Hide comment
@jeepstone

jeepstone Mar 26, 2014

I find that if I update to Less 1.7 using either NPM or by just dropping the files in, Winless updates to 1.7 but I'm then unable to write my compiled CSS files to the server. They compile correctly but nothing is output. The individual LESS files all compile on their own. I'm guessing this is a permissions issue somewhere?

I find that if I update to Less 1.7 using either NPM or by just dropping the files in, Winless updates to 1.7 but I'm then unable to write my compiled CSS files to the server. They compile correctly but nothing is output. The individual LESS files all compile on their own. I'm guessing this is a permissions issue somewhere?

@kvnbst

This comment has been minimized.

Show comment Hide comment
@kvnbst

kvnbst May 7, 2014

@jeepstone I am experiencing the same thing. I used the instructions in this thread to manually update WinLess to LESS.js 1.7 to fix an error that I was receiving when compiling. I no longer receive the error, but the CSS output file does not appear to be overwritten with the latest compiled version. Running WinLess as an administrator makes no difference, in my case.

kvnbst commented May 7, 2014

@jeepstone I am experiencing the same thing. I used the instructions in this thread to manually update WinLess to LESS.js 1.7 to fix an error that I was receiving when compiling. I no longer receive the error, but the CSS output file does not appear to be overwritten with the latest compiled version. Running WinLess as an administrator makes no difference, in my case.

@marklagendijk

This comment has been minimized.

Show comment Hide comment
@marklagendijk

marklagendijk Nov 5, 2014

Owner

Removed support for updating the bundled less, in version 1.9.0. Instead you can now choose to use the globally installed less.

Owner

marklagendijk commented Nov 5, 2014

Removed support for updating the bundled less, in version 1.9.0. Instead you can now choose to use the globally installed less.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment