Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

tag 2.0.9rc1

  • Loading branch information...
commit 9b2ba8f9ef8d544cfd07d8d0053fa9f240799cd4 1 parent 1d537f9
@markokr authored
Showing with 44 additions and 1 deletion.
  1. +3 −0  AUTHORS
  2. +1 −1  Makefile
  3. +34 −0 NEWS
  4. +6 −0 debian/changelog
View
3  AUTHORS
@@ -14,8 +14,11 @@ Marko Kreen
Contributors
------------
Hiroshi Saito
+Ian Sollars
+João Matos
Jonah Harris
Lei Yonghua
+Peter Eisentraut
Steve Singer
Ye Wenbin
View
2  Makefile
@@ -1,6 +1,6 @@
# PL/Proxy version
-PLPROXY_VERSION = 2.0.8
+PLPROXY_VERSION = 2.0.9rc1
# libpq config
PQINC = $(shell pg_config --includedir)
View
34 NEWS
@@ -1,3 +1,37 @@
+2009-09-xx - PlProxy 2.0.9 - ""
+
+ = Features =
+
+ * More flexible CONNECT statement:
+
+ CONNECT func(..);
+ CONNECT argname;
+ CONNECT $argnum;
+
+ NB: giving untrusted users ability to specify full connect string creates
+ security hole. Eg it can used to read cleartext passwords from .pgpass/pg_service.
+ If such function cannot be avoided, it's access rights need to be restricted.
+
+ (Ian Sollars)
+
+ = Fixes =
+
+ * Avoid parsing "SELECT (" as function call. Otherwise following query
+ fails to parse: SELECT (0*0);
+ (Peter Eisentraut)
+
+ * Make scanner accept dot as standalone symbol. Otherwise following query
+ fails to parse: SELECT (ret_numtuple(1)).num, (ret_numtuple(1)).name;
+ (Peter Eisentraut)
+
+ * Argument type name length over 32 could cause buffer overflow.
+ (Ian Sollars)
+
+ * Fix crash with incoming NULL value in function containing SELECT
+ with different argument order. Due to thinko, NULL check was done
+ with query arg index, instead of function arg index.
+ (João Matos)
+
2009-01-16 - PlProxy 2.0.8 - "Simple Multi-Tentacle Arhitecture"
= Features =
View
6 debian/changelog
@@ -1,3 +1,9 @@
+plproxy2 (2.0.9rc1) unstable; urgency=low
+
+ * v2.0.9rc1
+
+ -- Marko Kreen <marko.kreen@skype.net> Tue, 15 Sep 2009 15:27:26 +0300
+
plproxy2 (2.0.8rc1) unstable; urgency=low
* v2.0.8rc1
Please sign in to comment.
Something went wrong with that request. Please try again.