Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

stm-conduit-0.4.1

  • Loading branch information...
commit c146658a6fd43f49254ea89f285122e4b20fa8c2 1 parent b179666
@qnikst qnikst authored
View
4 dev-haskell/stm-conduit/Manifest
@@ -1,3 +1,3 @@
-DIST stm-conduit-0.4.0.tar.gz 4380 RMD160 d09edfe2e29f8d8b621af94ec172349d1085e9e2 SHA1 bf6f8d64c42e5a79dd64a01a65d21e5bd7129951 SHA256 8df1fb0573a0242d29cace52c8a45bb5f10904089b8385e4c3c3b8a532d3d79f
-EBUILD stm-conduit-0.4.0.ebuild 1042 RMD160 e20d58267fdee17efd526541352fb5c510fc4ef1 SHA1 b94209fff4b763e53a313da6af98042ccbe5f6e0 SHA256 9639e147e50d2b42259da4d27b1008cd2fc9ab6bb9e065e3bde4d616c5237afa
+DIST stm-conduit-0.4.1.tar.gz 4388 RMD160 27e247213ba953ef28c0d06926bfd70ac3ba4b7c SHA1 6d63719c3cb31964ee930b93c906010cf4d33755 SHA256 354bca06a02380ee694424a93405bae3141b137f974e99a8915c1d3f082fac36
+EBUILD stm-conduit-0.4.1.ebuild 1017 RMD160 7bc2db95e7ce4904dc2029f8099019d02d728be4 SHA1 677f749d06a56efe47944ec8313e8b86c515c130 SHA256 6e4ab9cf20b26f902605d3a0190f197f9ab0b59cb02792c8d0667d8456becd37
MISC metadata.xml 302 RMD160 0de29e0da3a0009527480313f0e2f3217e421797 SHA1 11e730ec697bbe8705da00ef59a392a2a53777e8 SHA256 3e683c21f7fa43d0a2daf4ccbab69286e1e4c398a85ef10adb47d243e0d59a08
View
23 dev-haskell/stm-conduit/stm-conduit-0.4.0.ebuild → dev-haskell/stm-conduit/stm-conduit-0.4.1.ebuild
@@ -6,7 +6,7 @@
EAPI=4
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Introduces conduits to channels, and promotes using
@@ -17,23 +17,20 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE=""
RDEPEND="=dev-haskell/conduit-0.4*[profile?]
=dev-haskell/resourcet-0.3*[profile?]
=dev-haskell/stm-2.3*[profile?]
=dev-haskell/stm-chans-1.3*[profile?]
>=dev-haskell/transformers-0.2[profile?]
- <dev-haskell/transformers-0.4[profile?]
+ <=dev-haskell/transformers-0.4[profile?]
>=dev-lang/ghc-6.10.1"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8"
-
-src_prepare() {
- sed -e "s@transformers ==0.2.\*@transformers >=0.2 \&\& <0.4@"\
- -i "stm-conduit.cabal" || die "can't loosen deps"
-}
-
-src_configure() {
- cabal_src_configure $(use_enable test tests)
-}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ )"
Please sign in to comment.
Something went wrong with that request. Please try again.