Skip to content
[REACT] The Complete Intro to React, the fifth version
JavaScript CSS HTML
Branch: master
Clone or download
Pull request Compare This branch is even with btholt:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
src
.babelrc
.eslintrc.json
.gitattributes
.gitignore
.prettierrc
README.md
package-lock.json
package.json

README.md

All PRs and issues for the course code and website have been resolved as of November 29th, 2019. The code for each commit and branch has also been tested! 😀

Welcome to the Complete Intro to React v5 and Intermediate React v2!

See the course website here.

Before starting the course, please have VSCode or another code editor installed.

The master branch and commits within are all covered in Introduction to React v5. The other branches, excluding the gh-pages-src and gh-pages branches (these create the course website), are all covered in Intermediate React as modular segments that can be taken individually, or out of order.

Brian is using a font called Dankmono (not necessary to install -- just for those curious), but FiraCode is another great option. This course was written for and recorded by Frontend Masters. The code here is licensed under the Apache 2.0 license and the course notes are licensed under the Creative Commons Attribution-NonCommercial 4.0 International license.

Debugging

Parcel Issues:

Parcel is an ever evolving project that's just getting better. If you run into problems with it not respecting changes (particularly to your .babelrc or .env files) then delete the dist/ and the .cache/ directories. You can do this in bash by running from the root directoy of your project rm -rf dist/ .cache/ or just by deleting those directories in your editor. This will force Parcel to start over and not cache anything.

See this issue for more specific instructions.

Solution to "regeneratorRuntime is not defined"

The simplest solution is to cut the supported browsers list in your package.json file down to:

    "browserslist": [
        "last 2 Chrome versions",
    ]

There is a more involved solution if you want to support more browsers in the issue.

If you run into anything else, open an issue and we'll try to clarify or help!

See a Bug or Typo?

Pull requests are extremely welcome! If you see a typo in the course website, you can access the website code through the gh-pages-src branch of this repository.

You can’t perform that action at this time.