Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Drop Python 2 and 3.5 support #241

Closed
sloria opened this issue Aug 31, 2019 · 6 comments · Fixed by #244

Comments

@sloria
Copy link
Member

commented Aug 31, 2019

@mgasner

This comment has been minimized.

Copy link

commented Sep 6, 2019

Just FYI, this broke Apache Airflow on py2 and 3.5

@AbdealiJK

This comment has been minimized.

Copy link
Collaborator

commented Sep 6, 2019

Apache airflow doesn't seem to be using this library from what I can see in their setup.py
https://github.com/apache/airflow/blob/1b1d79c0a67ba5a41efefe1a6d8df4c335869b43/setup.py

@mgasner

This comment has been minimized.

Copy link

commented Sep 6, 2019

Apache Airflow has a transitive dependency through Flask-AppBuilder, see dpgaspar/Flask-AppBuilder#1111 and https://issues.apache.org/jira/browse/AIRFLOW-5430. This is a major breaking change and it would be courteous to bump the major version.

@AbdealiJK

This comment has been minimized.

Copy link
Collaborator

commented Sep 6, 2019

To be honest, I'm not too sure it warrants a major version change.
Projects like pandas and numpy are in a similar boat and have not changed major versions to drop py2 support.
Obviously this opinion differs from project to project, and person to person.

In my opinion minor version bump should be sufficient with an appropriate changelog.
But other maintainers should probably comment too.

@mgasner

This comment has been minimized.

Copy link

commented Sep 6, 2019

It's pragmatic -- many of your downstream dependencies, like airflow, are pinned to <1.0.0, expecting that breaking changes will come with a major version bump.

@sloria

This comment has been minimized.

Copy link
Member Author

commented Sep 6, 2019

many of your downstream dependencies, like airflow, are pinned to <1.0.0, expecting that breaking changes will come with a major version bump.

Per semver, users should expect breaking changes for middle version number bumps because this is pre-1.0. So it's incorrect to pin to <1.0.0. To allow for patches, you should use e.g. ~=0.18.0 or >=0.18.0,0.18.*.

mgasner added a commit to dagster-io/dagster that referenced this issue Sep 6, 2019
Repin transitive dependency
Summary:
Transitive dependency dropped support for py2 and 3.5, breaking airflow initdb. See:
- https://issues.apache.org/jira/browse/AIRFLOW-5430
- dpgaspar/Flask-AppBuilder#1111
- marshmallow-code/marshmallow-sqlalchemy#241

Test Plan: Unit

Reviewers: #ft, alangenfeld, natekupp

Reviewed By: #ft, alangenfeld, natekupp

Subscribers: natekupp

Differential Revision: https://dagster.phacility.com/D956
mgasner added a commit to dagster-io/dagster that referenced this issue Sep 10, 2019
Repin transitive dependency
Summary:
Transitive dependency dropped support for py2 and 3.5, breaking airflow initdb. See:
- https://issues.apache.org/jira/browse/AIRFLOW-5430
- dpgaspar/Flask-AppBuilder#1111
- marshmallow-code/marshmallow-sqlalchemy#241

Test Plan: Unit

Reviewers: #ft, alangenfeld, natekupp

Reviewed By: #ft, alangenfeld, natekupp

Subscribers: natekupp

Differential Revision: https://dagster.phacility.com/D956
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.