Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix for stack level too deep error #4

Merged
merged 1 commit into from

2 participants

@jkraemer

Hi,

I encountered a stack level too deep error on any request (dev mode, redmine 1.4) that could be fixed by adding 'require application_controller' to application_patch.

Cheers,
Jens

@jkraemer jkraemer fix stacklevel too deep error
- caused by missing require application_controller
b3b7b30
@martin-denizet martin-denizet merged commit 81a6871 into martin-denizet:master
@martin-denizet

Thank you very much Jens!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 12, 2012
  1. @jkraemer

    fix stacklevel too deep error

    jkraemer authored
    - caused by missing require application_controller
This page is out of date. Refresh to see the latest.
Showing with 7 additions and 7 deletions.
  1. +5 −4 init.rb
  2. +2 −3 lib/application_patch.rb
View
9 init.rb
@@ -11,8 +11,9 @@
author_url 'https://github.com/martin-denizet'
description 'Attach screenshots from clipboard directly to a Redmine issue'
version '0.1.4'
- Dispatcher.to_prepare do
- ApplicationController.send(:include, AttachScreenshotPlugin::ApplicationControllerPatch)
- AccountController.send(:include, AttachScreenshotPlugin::CleanupTmp)
- end
+end
+
+Dispatcher.to_prepare do
+ ApplicationController.send(:include, AttachScreenshotPlugin::ApplicationControllerPatch)
+ AccountController.send(:include, AttachScreenshotPlugin::CleanupTmp)
end
View
5 lib/application_patch.rb
@@ -1,5 +1,4 @@
-require 'account_controller'
-require 'ftools'
+require 'application_controller'
module AttachScreenshotPlugin
module ApplicationControllerPatch
@@ -19,6 +18,6 @@ def find_current_user_with_screenshot
find_current_user_without_screenshot
end
end
- end
+ end
end
end
Something went wrong with that request. Please try again.