Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Memcache Store Rails plugin with missing implementation of delete_matched() . If you're using Memcache as your caching storage and you have problem with expire_fragmet() raising exception "Not supported by Memcache" than this plugin is going to help you.
Ruby
branch: master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib
spec
.gitignore
README
Rakefile
init.rb

README

MemCache Store with delete_matched
================
Author: Ladislav Martincik (ladislav.martincik@gmail.com)

= Description
If you're using default Memcache store provided by Rails (2.1) you're probably missing delete_matched() method used by expire_fragment() to clear cache with Regex. This plugin is implementation of this delete_matched(). It's not memcache implementation but simple Ruby code to provide this functionality. 

= Installation with Rails >2.1
script/plugin install git://github.com/lacomartincik/memcache-store-with-delete_matched.git

= Requirements
  - Memcache
  - memcache-client gem
  - rspec for running tests
Something went wrong with that request. Please try again.