Mattermost API v4 client for ruby
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
bin fix gem name in bin/console Jan 9, 2018
lib change internal http client (fix #6) Jan 30, 2018
.gitignore initial commit Jan 8, 2018
.rspec initial commit Jan 8, 2018
.travis.yml initial commit Jan 8, 2018
CHANGELOG.md bump version Jan 30, 2018
Gemfile initial commit Jan 8, 2018
LICENSE.txt initial commit Jan 8, 2018
README.md update README.md Jan 22, 2018
Rakefile initial commit Jan 8, 2018
mattermost-api4-ruby.gemspec bump version Jan 30, 2018

README.md

mattermost-api4-ruby

Mattermost API v4 client for ruby

Installation

Add this line to your application's Gemfile:

gem 'mattermost-api4-ruby'

And then execute:

$ bundle

Or install it yourself as:

$ gem install mattermost-api4-ruby

Usage

TODO: Write usage instructions here

Development

After checking out the repo, run bin/setup to install dependencies. Then, run rake spec to run the tests. You can also run bin/console for an interactive prompt that will allow you to experiment.

To install this gem onto your local machine, run bundle exec rake install. To release a new version, update CHANGELOG.md by bundle exec github_changelog_generator --future-release=<new version> maruTA-bis5/mattermost-api4-ruby, update the version number in gemspec, and then run bundle exec rake release, which will create a git tag for the version, push git commits and tags, and push the .gem file to rubygems.org.

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/maruTA-bis5/mattermost-api4-ruby.

License

The gem is available as open source under the terms of the MIT License.