installing iodocs with node v0.8.2 #41

Closed
lornajane opened this Issue Sep 11, 2012 · 2 comments

Comments

Projects
None yet
2 participants

(disclaimer: I'm quite a newbie at node, my experience is in other scripting languages)

I am trying to install iodocs on my ubuntu machine. Running npm install makes express give errors about my node version:

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: express@2.5.8
npm ERR! Required: {"node":">= 0.4.1 < 0.7.0"}
npm ERR! Actual: {"npm":"1.1.16","node":"0.8.2"}
npm ERR!
npm ERR! System Linux 3.0.0-21-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install"
npm ERR! cwd /home/lorna/svndir/iodocs/lornajane
npm ERR! node -v v0.8.2
npm ERR! npm -v 1.1.16
npm ERR! code ENOTSUP
npm ERR! message Unsupported
npm ERR! errno {}

I installed the current express version, but that's v3.0.0rc4 and that made things worse. I found this stackoverflow question helpful: http://stackoverflow.com/questions/9577988/install-iodocs-on-linux but I'm not any further forward.

What versions of node/express can I use? RTFM links and other pointers are all gratefully received - I have a REST API that I think would be a great use of iodocs if I could only get this going :)

@ghost ghost assigned mansilladev Sep 13, 2012

Contributor

mansilladev commented Sep 13, 2012

Later this afternoon I'll modify the package.json config to work with latest release (0.8.9). It's just a matter of package version ranges defined in package.json.

I upgraded my node to 0.8.9 to reproduce and was able to install fine. I have a pull request to improve error handling but I guess the problems I was having were due to a slightly outdated version of node/npm. Thanks

@lornajane lornajane closed this Sep 16, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment