Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Code coverage metrics for Perl

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 lib
Octocat-spinner-32 test_output
Octocat-spinner-32 tests
Octocat-spinner-32 BUGS
Octocat-spinner-32 CHANGES
Octocat-spinner-32 Cover.xs
Octocat-spinner-32 MANIFEST
Octocat-spinner-32 META.yml
Octocat-spinner-32 Makefile.PL
Octocat-spinner-32 README
Octocat-spinner-32 TODO
Octocat-spinner-32 cover
Octocat-spinner-32 cpancover
Octocat-spinner-32 create_gold
Octocat-spinner-32 gcov2perl
Octocat-spinner-32 session.vim
README
NAME
    Devel::Cover - Code coverage metrics for Perl

DESCRIPTION
    This module provides code coverage metrics for Perl.

    If you can't guess by the version number this is an alpha release.

    Code coverage data are collected using a pluggable runops function which
    counts how many times each op is executed. These data are then mapped
    back to reality using the B compiler modules. There is also a statement
    profiling facility which needs a better backend to be really useful.

    The cover program can be used to generate coverage reports.

    Statement, branch, condition, subroutine, pod and time coverage
    information is reported. Statement coverage data should be reasonable,
    although there may be some statements which are not reported. Branch and
    condition coverage data should be mostly accurate too, although not
    always what one might initially expect. Subroutine coverage should be as
    accurate as statement coverage. Pod coverage comes from Pod::Coverage.
    Coverage data for path coverage are not yet collected.

    The gcov2perl program can be used to convert gcov files to Devel::Cover
    databases.

    You may find that the results don't match your expectations. I would
    imagine that at least one of them is wrong.

    THe most appropriate mailing list on which to discuss this module would
    be perl-qa. Discussion has migrated there from perl-qa-metrics which is
    now defunct. http://lists.perl.org/showlist.cgi?name=perl-qa

    Requirements:

      Perl 5.6.1 or greater.  (Perl 5.7.0 is also unsupported.)
      The ability to compile XS extensions.
      Pod::Coverage if you want pod coverage.
      Template Toolkit 2 if you want HTML output.

Something went wrong with that request. Please try again.