Permalink
Browse files

Removed AMD require of underscore lib

  Underscore is no longer AMD compatible and thus any implementations
  that use require() must deal with dependencies manually. This does
  not belong in master at the very least.
  • Loading branch information...
Steven Lindberg
Steven Lindberg committed Mar 14, 2012
1 parent 48ff474 commit 5304054770b96a34497785172dee6de18cbf9fd7
Showing with 2 additions and 7 deletions.
  1. +1 −7 backbone.subset.js
  2. +1 −0 test/test.js
View
@@ -5,13 +5,7 @@
*/
(function () {
- var root = this
- , Subset = {}
- , _ = root._;
-
- if (!_ && (typeof require !== 'undefined')) {
- _ = require('underscore')._;
- }
+ var Subset = {}
/**
* Subset constructor
View
@@ -14,6 +14,7 @@ function inc(what) {
};
}
+GLOBAL._ = _
GLOBAL.Backbone = require('backbone');
require('../backbone.subset');

0 comments on commit 5304054

Please sign in to comment.