A Danger plugin for managing dependency file versions.
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
lib
spec
.gitignore
.travis.yml
Gemfile
Guardfile
LICENSE.txt
README.md
Rakefile
danger-lock_dependency_versions.gemspec

README.md

Build Status

danger-lock_dependency_versions

A Danger plugin for managing dependency files.

Check files which should be committed together to version control (e.g., Gemfile and Gemfile.lock, Cartfile and Cartfile.resolved).

Installation

Add this line to your Gemfile:

$ gem danger-lock_dependency_versions

Usage

First, create .lock_list.yml and add key-value pair to check.

Gemfile: Gemfile.lock
Cartfile: Cartfile.resolved

Add to Dangerfile.

lock_dependency_versions.check

If lockfile has not committed to version control, post a failure comment by Danger.

Methods

check(warning: boolean)

if specify warning: true, set comment status to warning. (default: false)