Skip to content
Permalink
Browse files

Drop dbus-glib dependence

  • Loading branch information...
yetist authored and raveit65 committed May 8, 2018
1 parent dccffbc commit 8217f2d58544c3f25bd793091593d616b4f0fd1d
Showing with 1 addition and 4 deletions.
  1. +1 −4 configure.ac
@@ -90,16 +90,13 @@ dnl ---------------------------------------------------------------------------
dnl Requirements for the daemon
dnl ---------------------------------------------------------------------------
REQ_GLIB_VERSION=2.50.0
REQ_DBUS_VERSION=0.78
REQ_LIBCANBERRA_GTK_VERSION=0.4
PKG_CHECK_MODULES(GMODULE,gmodule-2.0,[GMODULE_ADD="gmodule-2.0"],[GMODULE_ADD=""])
pkg_modules="
gtk+-3.0 >= $GTK_REQUIRED, \
glib-2.0 >= $REQ_GLIB_VERSION, \
gio-2.0 >= $REQ_GLIB_VERSION, \
$GMODULE_ADD \
dbus-1 >= $REQ_DBUS_VERSION, \
dbus-glib-1 >= $REQ_DBUS_VERSION, \
libcanberra-gtk3 >= $REQ_LIBCANBERRA_GTK_VERSION, \
libwnck-3.0 \
x11 \
@@ -111,7 +108,7 @@ AC_SUBST(NOTIFICATION_DAEMON_LIBS)
dnl ---------------------------------------------------------------------------
dnl Requirements for the setup tool
dnl ---------------------------------------------------------------------------
PKG_CHECK_MODULES(NOTIFICATION_CAPPLET, glib-2.0 >= $REQ_GLIB_VERSION gio-2.0 >= $REQ_GLIB_VERSION gtk+-3.0 >= $GTK_REQUIRED libnotify dbus-1 dbus-glib-1)
PKG_CHECK_MODULES(NOTIFICATION_CAPPLET, glib-2.0 >= $REQ_GLIB_VERSION gio-2.0 >= $REQ_GLIB_VERSION gtk+-3.0 >= $GTK_REQUIRED libnotify)
AC_SUBST(NOTIFICATION_CAPPLET_CFLAGS)
AC_SUBST(NOTIFICATION_CAPPLET_LIBS)

0 comments on commit 8217f2d

Please sign in to comment.
You can’t perform that action at this time.