require GTK+ >= 3.14, drop GTK+2 code and --with-gtk build option #28

Merged
merged 1 commit into from May 26, 2016

Projects

None yet

5 participants

@monsta
Member
monsta commented May 18, 2016

@flexiondotorg @clefebvre @raveit65 @posophe @XRevan86 @willysr @obache @NP-Hardass

And now we move mate-polkit to GTK+3:

  • minimum GTK+ version is set to 3.14
  • GTK+2 code and deprecated GTK+3 code are dropped
  • --with-gtk build option is dropped as well
  • build-deps on GTK+ and appindicator dev packages are changed (that's what you need to do in your distros)

For example, in Debian/Ubuntu build-deps are changed as follows:
libappindicator-dev -> libappindicator3-dev
libgtk2.0-dev -> libgtk-3-dev

@willysr
willysr commented May 18, 2016

+1 from me

@flexiondotorg
Member

+1

@raveit65
Member

Looks like people thinks this is a voting 😄
...i think @monsta wants that people test the commit.
...building.......installation.......runtime 😉

@monsta
Member
monsta commented May 21, 2016

It's also a notification for distro maintainers so they won't get a surprise when 1.16 is released 😄

@lukefromdc
Member

Tested and works here, clicked on an internal volume in the Caja sidebar and the pasword dialog worked normally and was able to give permission to mount the drive.

@monsta monsta merged commit a9222b1 into master May 26, 2016
@monsta monsta deleted the dev-gtk3-migration branch May 26, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment