Required Software

Vinay Amatya edited this page Jul 16, 2018 · 18 revisions

MaTEx-TensorFlow supports the following software packages:

  • GCC 4.9.2 or above (also tested with 4.8.5)
  • OpenMPI 1.8.3 or above
  • MVAPICH2 2.1a or above
  • Python 3.5.x
  • Autoconf, Make and m4
  • Anaconda(python) and PIP 8 or above
  • For GPU enabled clusters: CUDNN 7.0 and CUDA 9.1

** Officially TensorFlow does not support glibc < 2.19. However, we have a workaround to address this problem. Please take a look at MaTEx-TensorFlow on Older glibc(v<2.19) **