Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Left and right mouse button lag #32

Closed
matlo opened this issue Nov 27, 2013 · 6 comments
Closed

Left and right mouse button lag #32

matlo opened this issue Nov 27, 2013 · 6 comments

Comments

@matlo
Copy link
Owner

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on February 01, 2011 10:24:59

The goal of this issue is not to report a bug, but to warn people about a xorg problem that impacts left and right mouse buttons.

This problem is related to a xorg functionality called "3rd button emulation" that is useful with a 2 button mouse. Xorg waits 50ms to see if both left and right buttons are pressed, and in case it is, it generates a middle button press.

Following bug reports were filled by people complaining about that behavior:

* https://bugs.freedesktop.org//show_bug.cgi?id=1752 * https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/291694 Although a real middle button press is enough to disable the functionality, it's possible to disable it by default. Details about how to do that are given in the two bug reports.

Original issue: http://code.google.com/p/diyps3controller/issues/detail?id=30

@matlo
Copy link
Owner Author

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on February 02, 2011 04:17:18

Persistent work around for Ubuntu 10.10:

sudo gedit /usr/share/X11/xorg.conf.d/20-mouse.conf

Copy-paste to following lines:

Section "InputClass"
Identifier "Mouse0"
MatchIsPointer "true"
Option "Emulate3Buttons" "false"
EndSection

Save, and Restart!

@matlo
Copy link
Owner Author

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on February 03, 2011 00:05:23

Labels: -Type-Defect Type-Other

@matlo
Copy link
Owner Author

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on February 17, 2011 06:50:13

Status: Done

@matlo
Copy link
Owner Author

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on April 15, 2011 07:22:34

It seems a good idea to use the XIChangeProperty method to automatically disable "Middle Button Emulation" when the sixaxis emulator is started.

People are probably running the sixaxis emulator without realizing they get this lag.

Status: Accepted

@matlo
Copy link
Owner Author

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on May 02, 2011 13:56:17

It's now off by default (Ubuntu 11.04) => no action.

Status: Done

@matlo
Copy link
Owner Author

@matlo matlo commented Nov 27, 2013

From mathieu....@gmail.com on February 06, 2012 04:48:55

Status: WontFix

@matlo matlo closed this Nov 27, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant