Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The wrong segment may be selected in the Segment editor #11787

Closed
mattab opened this issue Jun 13, 2017 · 0 comments · Fixed by #11790
Closed

The wrong segment may be selected in the Segment editor #11787

mattab opened this issue Jun 13, 2017 · 0 comments · Fixed by #11790
Assignees
Labels
Milestone

Comments

@mattab
Copy link
Member

@mattab mattab commented Jun 13, 2017

After creating a new segment, the reports try hard to apply this new segment instead of the last selected segment.

How to reproduce:

  • Go to Visitor Log (or any report)
  • Click Add new segment (any segment will do) called Test segment
  • Click Save & Apply
  • Note the URL query string (before hash tag) includes the &segment= parameter
  • The visitor log displays the Test segment visits (as expected)
  • Click on All Visits in segment editor
  • The visitor log displays all visits (as expected)
  • Then click on any other menu link, such as Overview.
  • Got: the report applies segment Test segment
  • Expected: the report should apply the previously clicked segment ie. All Visits

(Seems the problem is that we set the &segment= parameter in the URL before hash tag and it gets read and set after the hash tag. Wondering why we set this &segment= in the query string in the first place)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.