New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

E-Mail addresses with special characters are not working #11796

Open
Findus23 opened this Issue Jun 15, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@Findus23
Copy link
Member

Findus23 commented Jun 15, 2017

If one tries to add a new user with the email address john's.email@example.com piwik returns The email doesn't have a valid format. even though the address is perfectly valid.
A var_dump($emailAddress) in this line shows that the all special characters get converted to HTML entities.

  • john's.email@example.com => john's.email@example.com
  • "very.unusual.@.unusual.com"@example.com => "very.unusual.@.unusual.com"@example.com
  • !#$%&'*+-/=?^_{|}~@example.com => !#$%&'*+-/=?^_{|}~@example.com

@mattab mattab added the Bug label Jun 21, 2017

@mattab mattab added this to the Priority Backlog (Help wanted) milestone Jun 21, 2017

@mattab mattab removed this from the Priority Backlog (Help wanted) milestone Oct 6, 2017

@ghost ghost referenced this issue Mar 9, 2018

Closed

Fix email html encoding #12611

@mattab mattab modified the milestones: 3.3.1, 3.4.0, 3.4.1 Mar 19, 2018

@mattab mattab modified the milestones: 3.5.0, 3.6.0 Apr 23, 2018

@Findus23

This comment has been minimized.

Copy link
Member Author

Findus23 commented Jul 1, 2018

In case someone wants to fix this, please take a look at #12611 and the suggested changes there.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment