New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pivoting by custom dimension results in an error #13317

Closed
tsteur opened this Issue Aug 20, 2018 · 0 comments

Comments

Projects
None yet
3 participants
@tsteur
Member

tsteur commented Aug 20, 2018

FYI: This looks like some bug in core where a custom dimension is not found in https://github.com/matomo-org/matomo/blob/3.6.0-rc1/core/DataTable/Filter/PivotByDimension.php#L322
image

The ID of the dimension is CustomDimension.CustomDimension1.

image

The problem is that the factory only includes hard coded dimensions in https://github.com/matomo-org/matomo/blob/3.6.0-rc1/core/Columns/Dimension.php#L830 vs all dynamically included dimensions are ignored in https://github.com/matomo-org/matomo/blob/3.6.0-rc1/core/Columns/Dimension.php#L773

Just a guess... You can reproduce it with Custom Reports and eg using a Visit dimension plus a Custom Dimensions dimension.

@tsteur tsteur added the Bug label Aug 20, 2018

@tsteur tsteur added this to the 3.7.0 milestone Aug 20, 2018

@mattab mattab modified the milestones: 3.7.0, 3.6.1 Sep 1, 2018

@diosmosis diosmosis self-assigned this Sep 12, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment