Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

#13113 not fixxed - segmented visitors empty if url contains whitespaces #13460

Open
fdellwing opened this issue Sep 20, 2018 · 4 comments

Comments

@fdellwing
Copy link
Contributor

commented Sep 20, 2018

@sgiehl I just took a look at this with your fix applied and it is not fixxed for me.

matomo2

@fdellwing

This comment has been minimized.

Copy link
Contributor Author

commented Sep 20, 2018

This PR should have fixxed it: #13198

@eetasse

This comment has been minimized.

Copy link

commented Sep 20, 2018

I confirmed #13113 not fixed in 3.6.0.

URL Sent to Matomo : https://........./display/~EtasseE/Backup+plan+October+2017
In the Matomo UI (Behaviour|Page screens) we have: https://........./display/~EtasseE/Backup plan October 2017

The + (PLUS) chars have been replaced with whitepaces. As a consequence the "Open Segmented Visitor Log" does not show any data. As soon there is one whitepace in the "page URL" on this screen it does not work.

@diosmosis diosmosis added this to the 3.6.1 milestone Sep 20, 2018

@diosmosis diosmosis added the Bug label Sep 20, 2018

@diosmosis

This comment has been minimized.

Copy link
Member

commented Sep 23, 2018

Don't have a fix yet, but found the cause of the error. Actions are stored urlencoded in the log_action table, but the value in the segment when opening the segmented visitor log/transitions modal/etc. is not. This results in Matomo looking for an idaction where the name is, eg, example.org/with+plus-sign/ instead of exampleo.org/with%2Bplus-sign/. Somewhere the value is either getting urldecoded or needs to be urlencoded.

@ramramra

This comment has been minimized.

Copy link

commented Dec 20, 2018

Hi all ,
I am using Matomo 3.6.1 version in linux environment i use this for my website end user information tracking .we are able to tracking end user info but we facing no data in segmented visitor log .we check in SegmentedVisitorlog .js filse is also fine and there is no white space in my url .I will attach sample url which i requested .More over we are facing another main issue Matomo is running very slow and it takes more than 2 minutes to show dashboards and page view .The DB we are using working fine and PHP we are using Latest version even we are facing this issues can any one help me for this 2 issues .Thanks in advance.

Sample URL: http://localhost:5601/app/kibana#/dashboard/74c2c040-e917-11e8-84c1-e90cb502923b?_g=()&_a=(description:'',filters:!(),fullScreenMode:!f,options:(darkTheme:!f,hidePanelTitles:!f,useMargins:!t),panels:!((gridData:(h:3,i:'1',w:6,x:0,y:0),id:e2a4bec0-e916-11e8-84c1-e90cb502923b,panelIndex:'1',type:visualization,version:'6.2.1'),(gridData:(h:3,i:'2',w:6,x:6,y:0),id:e2a4bec0-e916-11e8-84c1-e90cb502923b,panelIndex:'2',type:visualization,version:'6.2.1'),(gridData:(h:3,i:'3',w:6,x:0,y:3),id:e2a4bec0-e916-11e8-84c1-e90cb502923b,panelIndex:'3',type:visualization,version:'6.2.1'),(gridData:(h:3,i:'4',w:6,x:6,y:3),id:e2a4bec0-e916-11e8-84c1-e90cb502923b,panelIndex:'4',type:visualization,version:'6.2.1')),query:(language:lucene,query:''),timeRestore:!f,title:awscloud,viewMode:view)

@mattab mattab modified the milestones: 3.8.0, 3.9.0 Dec 31, 2018

@mattab mattab modified the milestones: 3.9.0, 3.10.0 Mar 18, 2019

@mattab mattab modified the milestones: 3.10.0, 3.12.0 Jun 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.