New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

re-run scheduled report manually for previous months data #14066

Closed
davidtessier opened this Issue Feb 1, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@davidtessier
Copy link

davidtessier commented Feb 1, 2019

I am wondering how I can re-run a monthly scheduled report, and get the previous month's data? This seems like a bug to me...

I started using Matomo in January, so I have partial data for the month. I've setup a monthly email report, and I setup a cronjob to run it at 10:00 my time (15 o'clock UTC ).

Since today is the 1st day of January...
I got the automated email report (good)
I got it at 10:00am as expected (good)
The report showed the data for January (good)
All of this worked as I would expect.

Here's what's weird to me...
I want to re-run the report. So I log into Matomo, settings, email reports, and I click "send report now".
The same report gets emailed to me right away, but it's showing data for the month of February. Since we're only 14 hours into February there's not a lot of data yet... I wanted to re-run the report, and I would have expected to see January's data, like I got in the automated email. The same data is presented when I click "download" instead of "send report now".

How come I am seeing February when I re-run manually, and is there a way to re-send the report and get the previous month's data? I don't see any option for this in the UI.

2019-02-01 14_18_59-personal email reports - administration - matomo

@tsteur

This comment has been minimized.

Copy link
Member

tsteur commented Feb 1, 2019

When you click on Download, you can change the date in the URL parameter and then you should get the report you want.

@tsteur tsteur closed this Feb 1, 2019

@tsteur tsteur added the answered label Feb 1, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment