Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tracking Failures not working with invalid siteId #19339

Open
uxfrank opened this issue Jun 10, 2022 · 1 comment
Open

Tracking Failures not working with invalid siteId #19339

uxfrank opened this issue Jun 10, 2022 · 1 comment
Labels
answered For when a question was asked and we referred to forum or answered it.

Comments

@uxfrank
Copy link

uxfrank commented Jun 10, 2022

We tried to validate the tracker failures feature by intentionally changing the siteId in our snippet to an invalid siteId (e.g. "-1", "2000", removing the siteId, etc).

None of these changes seemed to trigger the Logfailure() in Visit.php .

Is there a setup step that was missed?

Expected Behaviour

If a snippet has an invalid siteId, than a tracker failure should be logged in the admin diagnostics.

Current Behaviour

No tracking failures are logged.

Steps to Reproduce (for Bugs)

Within the javascript tracking code change the valid setSiteId to something invalid
e.g.
from
_paq.push(['setSiteId', '1']);

to
_paq.push(['setSiteId', '2000']);

browse to:
/index.php?module=CoreAdminHome&action=trackingFailures&idSite=1&period=day&date=today

Context

We're planning on using the on-premise version of Matomo and would like to have some built in tracker status monitoring.

Your Environment

On-premise, fully installed, no issues with the installation

  • Matomo Version: 4.9.1
  • PHP Version: 7.4.29
@uxfrank uxfrank added the Potential Bug Something that might be a bug, but can't be reproduced (yet). label Jun 10, 2022
@bx80
Copy link
Contributor

bx80 commented Jun 13, 2022

Hi @uxfrank, thanks making contact.

Any siteId less than 1 will be ignored, so setting the siteId to -1 will not log any tracking errors.
A siteId of 2000 should record a tracking failure (assuming you don't have a site with that id). I've tested this and a tracking failure was logged, so it doesn't seem to be a general bug.

If the visit is excluded for some reason (excluded IP, user agent, parameters,) then no tracking failure will be recorded, so it would be worth checking your site exclusions (Measurables > Manage) to see if there is anything that would cause your test visit to be excluded.

@peterhashair peterhashair added answered For when a question was asked and we referred to forum or answered it. and removed Potential Bug Something that might be a bug, but can't be reproduced (yet). labels Nov 10, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
answered For when a question was asked and we referred to forum or answered it.
Projects
None yet
Development

No branches or pull requests

4 participants