Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Segment just created, and real-time processing of segments is disabled, And Segment has no data, the message is not displayed at the top to warn it may take some time display #20060

Closed
mattab opened this issue Nov 29, 2022 · 13 comments
Assignees
Labels
wontfix If you can reproduce this issue, please reopen the issue or create a new one describing it.

Comments

@mattab
Copy link
Member

mattab commented Nov 29, 2022

expected notification:

image

we reproduced on Cloud this wasn't displayed after creating a segment.
This may be a regression in core?

@mattab mattab added Regression Indicates a feature used to work in a certain way but it no longer does even though it should. Potential Bug Something that might be a bug, but can't be reproduced (yet). To Triage An issue awaiting triage by a Matomo core team member labels Nov 29, 2022
@mattab mattab added this to the 4.13.0 milestone Nov 29, 2022
@justinvelluppillai justinvelluppillai removed To Triage An issue awaiting triage by a Matomo core team member Potential Bug Something that might be a bug, but can't be reproduced (yet). labels Nov 29, 2022
@heurteph-ei
Copy link

There was another issue about this notification in case of empty report (because no data, not because not processed), but impossible to find it again... 🤔

@justinvelluppillai
Copy link
Contributor

Let's make sure we add UI tests once this is resolved so we can catch if it regresses again

@sgiehl
Copy link
Member

sgiehl commented Nov 30, 2022

I'm actually not able to reproduce that problem locally. When browser archiving is disabled and I create a new segment the notification is shown. And there is a UI test for exact this case:

it("should show a notification for unprocessed segments", async function () {
testEnvironment.configOverride.General = {
browser_archiving_disabled_enforce: '1',
enable_browser_archiving_triggering: '0',
rearchive_reports_in_past_last_n_months: '0',
};
testEnvironment.optionsOverride = {
enableBrowserTriggerArchiving: '0',
};
testEnvironment.save();
await page.goto(url + '&segment=' + encodeURIComponent(segment));
expect(await page.screenshotSelector('.pageWrap,#notificationContainer')).to.matchImage('unprocessed_default_segment');
});

result

The only change around that logic I could find is #18540

@peterhashair
Copy link
Contributor

I can't reproduce this locally as well. Will try again today.

@justinvelluppillai justinvelluppillai modified the milestones: 4.13.0, 4.13.1 Dec 8, 2022
@justinvelluppillai
Copy link
Contributor

@mattab are you still able to reproduce this issue and provide info about the steps?

@mattab
Copy link
Member Author

mattab commented Dec 8, 2022

@justinvelluppillai it can be reproduced on Cloud (in our instance), but i haven't reproduced on on-premise yet, but you had maybe reproduced it before? or maybe it's just an issue on Cloud

@mattab mattab added the 4.13.1 label Jan 4, 2023
@mattab
Copy link
Member Author

mattab commented Jan 4, 2023

fyi reproduced today again on Cloud, created a random segment and there was no notification box:
image

@mattab
Copy link
Member Author

mattab commented Jan 9, 2023

Because the issue is only happening on Cloud, we will close it here, and Cloud team will investigate.

@mattab mattab closed this as not planned Won't fix, can't repro, duplicate, stale Jan 9, 2023
@mattab
Copy link
Member Author

mattab commented Jan 9, 2023

reproduced on demo2

@mattab mattab reopened this Jan 9, 2023
@sgiehl
Copy link
Member

sgiehl commented Jan 10, 2023

Relevant config values that are e.g. used on demo2:

browser_archiving_disabled_enforce = 1
enable_create_realtime_segments = 0
enable_browser_archiving_triggering = 0
process_new_segments_from = "last60"

@justinvelluppillai justinvelluppillai modified the milestones: 4.13.1, 4.13.2 Jan 11, 2023
@bx80
Copy link
Contributor

bx80 commented Jan 17, 2023

I can recreate this on locally and on demo2 by creating a new segment which will not return any visits for the selected time period.

For example:

  1. Use a site with a day selected containing only visits between say 6am to 11pm
  2. Create a new segment "Site - time hour is not 3am"
  3. The segment unprocessed message will be shown because there are visits for this segment in the selected time period.
  4. Create a new segment "Site - time hours is 3am"
  5. The segment unprocessed message will not be shown because there are no visits for this segment in the selected time period.
  6. Change the time period to a whole year where there will be some visits at 3am, now the segment unprocessed message will be shown.

This is because of the code 'if no visits recorded, data will not appear, so don't show the message'

This is intentional behavior added as part of #12823, but it's potentially confusing as experienced users wouldn't expect a new segment to be 'ready' immediately and seems a bit inconsistent that the segment will sometimes show as unprocessed depending on the selected period.

Possible changes:

  1. Disable the check and always show the unprocessed message until the segment has been processed even if there will be no data for that time period.
  2. Show a discreet info message: "Hey this segment is new and probably hasn't been processed for all periods yet, but there is no segment data for this particular time period anyway, so we're showing you a blank report"
  3. Leave it as is and add some explanatory documentation somewhere (probably not very helpful as it would be hard to find in a search)
  4. Better ideas?

@mattab Do you have any preferences on how to proceed with this?

@mattab
Copy link
Member Author

mattab commented Jan 17, 2023

I'd go with 1) to make things consistent & simple, maybe?

@mattab
Copy link
Member Author

mattab commented Jan 23, 2023

Closing due to complications to implement and not being worth it yet

@mattab mattab closed this as not planned Won't fix, can't repro, duplicate, stale Jan 23, 2023
@bx80 bx80 added wontfix If you can reproduce this issue, please reopen the issue or create a new one describing it. and removed Regression Indicates a feature used to work in a certain way but it no longer does even though it should. 4.13.1 labels Jan 24, 2023
@mattab mattab changed the title Segment just created, and real-time processing of segments is disabled, message is not displayed at the top to warn it may take some time display Segment just created, and real-time processing of segments is disabled, And Segment has no data, the message is not displayed at the top to warn it may take some time display Feb 16, 2023
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
wontfix If you can reproduce this issue, please reopen the issue or create a new one describing it.
Projects
None yet
Development

Successfully merging a pull request may close this issue.

6 participants