Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

If server is not using at least PHP 5.3, make sure Piwik displays a useful error message #4653

Closed
mattab opened this issue Feb 8, 2014 · 1 comment
Labels
Milestone

Comments

@mattab
Copy link
Member

@mattab mattab commented Feb 8, 2014

Our index.php should be compatible with older PHP versions such as PHP 4 and PHP 5.1 and PHP 5.2.

Currently it spits out a PARSE error when it hits the "use" statement. Instead, let's rewrite the index.php so that is is parsable by Php4 and early php5. This will prevent a lot of user frustration and support requests. See faq and Piwik requirements.

@mattab
Copy link
Member Author

@mattab mattab commented Feb 8, 2014

Fixed in 0a04031

@mattab mattab added this to the 2.1 - Piwik 2.1 milestone Jul 8, 2014
@mattab mattab added T: Bug labels Jul 8, 2014
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant