Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tooltip is unreadable #5000

Closed
anonymous-piwik-user opened this issue Apr 16, 2014 · 15 comments
Assignees
Labels
Bug
Milestone

Comments

@anonymous-piwik-user
Copy link

@anonymous-piwik-user anonymous-piwik-user commented Apr 16, 2014

The tooltip text that shows up when you hover in the visitors log is set to a very light grey color and the tooltip itself ha s awhite background.

I am unable to read the text in the tooltip.

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented Apr 16, 2014

Attachment: screenshot
tooltip.jpg

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented Apr 16, 2014

Woohoo bug #5000 lol... thanks.

@mattab

This comment has been minimized.

Copy link
Member

@mattab mattab commented Apr 16, 2014

Can you please post a screenshot?

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented Apr 16, 2014

Screnshot is there dude... 1st comment.

@mattab

This comment has been minimized.

Copy link
Member

@mattab mattab commented Apr 17, 2014

#5000 dude! high times!

The tooltip is looking good for me, with black background. I use Firefox 28 on linux. What about you?

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented Apr 20, 2014

My background is not black, how can I change the tooltip bg?

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented Apr 21, 2014

OK well nobody answered, so it was GREP to the rescue.

CSS files seem to be located in:

/tmp/assets

The file I edited was asset_manager_global_css.css

Does this file get regenerated often? How does this work?
I added background-color: #000; to all of the tooltip css styles and I can now read my tooltips.

@mattab

This comment has been minimized.

Copy link
Member

@mattab mattab commented Apr 27, 2014

Does this file get regenerated often? How does this work?
I added background-color: #000; to all of the tooltip css styles and I can now read my tooltips.

It should re-generated when activating/deactivating plugins that contain CSS (so the file is rebuilt). Also when upgrading piwik core.

It's strange you got white tooltips. It works locally. do you also see white tooltips using Chrome for example? or another browser?

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented May 1, 2014

Just in Firefox by the looks of it. Can I suggest a change to the code?
I did my own edit to the css file, which will eventually be overwritten.

For the ui-tooltip css elements can you add:

background-color: #000;

This will make it work. Have you tried installing Firefox yourselves to see if the error occurs on your installations as well? If so then this is a defacto bug. The tooltip is not useful if it is unreadable.

@mattab

This comment has been minimized.

Copy link
Member

@mattab mattab commented May 1, 2014

Sure we mostly use firefox at Piwik. Do you see the white tooltip background on the http://demo.piwik.org as well?

@anonymous-piwik-user

This comment has been minimized.

Copy link
Author

@anonymous-piwik-user anonymous-piwik-user commented May 2, 2014

Yes white tooltip background, unreadable in your demo.piwik.org site.

I have Firebug installed on my FF installation. That is the only extension I have running.

I just upgraded to the brand new Firefox, I had 28.. now I have 29.0 .. same problem.

How is it I'm the only one having this problem??

@mattab

This comment has been minimized.

Copy link
Member

@mattab mattab commented May 6, 2014

How is it I'm the only one having this problem??

That's also what I'm wondering... Do you see same issue when using Chrome or Opera?

@tsteur

This comment has been minimized.

Copy link
Member

@tsteur tsteur commented May 6, 2014

In 44aa8c9: fixes #5000 this should fix the white tooltip background, please reopen if it still does not work for you (will be probably in next new major release)

@ksubileau

This comment has been minimized.

Copy link
Contributor

@ksubileau ksubileau commented May 8, 2014

I also had this problem in previous versions on Firefox. The fix do the job in 2.2.2, but I think it's quite ugly... Why a white text on a black background, and not the opposite ? (See attached file)

@ksubileau

This comment has been minimized.

Copy link
Contributor

@ksubileau ksubileau commented May 8, 2014

@anonymous-piwik-user anonymous-piwik-user added this to the 2.3.0 - Piwik 2.3.0 milestone Jul 8, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
…lease reopen if it still does not work for you (will be probably in next new major release)
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.