Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

in Visitors - Overview, Action metrics not displayed when report purge is enabled #5054

Closed
anonymous-matomo-user opened this issue Apr 28, 2014 · 16 comments
Labels
Bug For errors / faults / flaws.
Milestone

Comments

@anonymous-matomo-user
Copy link

hi there,

just did recently wiped all reports older than 3 months, keeping weekly, monthly and yearly.

When I go Actions - Downloads and select e.g. data in last September and

select some day - correctly give message that report doesn't exist - pw_downloads_day.png

select some week - correctly shows data - pw_downloads_week.png

Now going to Visitors - Overview, selecting exactly same week and choosing Download/Unique downloads it shows flat - pw_visitor_log.png

Since data are apparently in Piwik as seen in Actions tab, I guess this is defect. Visitor logs from that period are wiped, so it must be taken from archive.

Piwik 2.2.0

@anonymous-matomo-user
Copy link
Author

Attachment:
pw_downloads_day.png

@anonymous-matomo-user
Copy link
Author

Attachment:
pw_downloads_week.png

@anonymous-matomo-user
Copy link
Author

Attachment:
pw_visitor_log.png

@mattab
Copy link
Member

mattab commented Apr 30, 2014

Thanks for the report. Could you also attach the settings for the "Delete old report" in Settings>Privacy?

@anonymous-matomo-user
Copy link
Author

Attachment:
settings.png

@anonymous-matomo-user
Copy link
Author

See attached settings.png - purge is set to weekly (too small screen to capture it whole) ...

@tsteur
Copy link
Member

tsteur commented May 7, 2014

In c9c5e79: refs #5054 this fixes all rows for all periods in old numeric tables were deleted instead of keeping the selected ones

@tsteur
Copy link
Member

tsteur commented May 7, 2014

In 3bb6a01: refs #5054 if no period should be kept do not append where clause to prevent mysql error

@tsteur
Copy link
Member

tsteur commented May 8, 2014

In c103d03: refs #5054 some more bug fixes and tests

@tsteur
Copy link
Member

tsteur commented May 8, 2014

In da9cd11: refs #5054 added integration flag

@tsteur
Copy link
Member

tsteur commented May 8, 2014

In 49cb0c5: refs #5054 some code improvements

@tsteur
Copy link
Member

tsteur commented May 8, 2014

Fixed. The numeric archives for all periods were deleted when "delete old reports" was enabled instead of keeping the selected ones. It worked fine for blob archives. This explains why data was there in the Downloads report but not in the evolution. Although this bug is fixed the data won't appear in the evolution afterwards as it only fixes future "delete old reports".

@tsteur
Copy link
Member

tsteur commented May 8, 2014

In f5c2d9b: refs #5054 fix some tests

@anonymous-matomo-user
Copy link
Author

Thanks for the fix ... I have of course backup of db, but since some time passed, I cannot simply restore it. If I just replace piwik_archive_numeric_201X_XX from backup will it work? How about January archive, it holds yearly reports if I got it right, so can I replace Jan as well and it would re-create reports on next auto-archive?

@tsteur
Copy link
Member

tsteur commented May 8, 2014

If you just restore those piwik_archive_numeric_201X_XX tables it should work fine as the blobs should be still there. No need to re-archive then. It should just work. @matt can you confirm?

@anonymous-matomo-user
Copy link
Author

I just did that and it works pretty fine, all reports are back and kept after purging as well.

@anonymous-matomo-user anonymous-matomo-user added this to the 2.3.0 - Piwik 2.3.0 milestone Jul 8, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
…ic tables were deleted instead of keeping the selected ones
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Bug For errors / faults / flaws.
Projects
None yet
Development

No branches or pull requests

3 participants