Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

'Page Name not defined' in page title reports - Outlinks being tracked as pages #5113

Closed
anonymous-matomo-user opened this issue May 8, 2014 · 5 comments
Assignees
Labels
Bug For errors / faults / flaws. Major Indicates the severity or impact or benefit of an issue is much higher than normal but not critical.
Milestone

Comments

@anonymous-matomo-user
Copy link

Since 2.2.1 there is a line with 'page name not defined' in my stats. (today's update 2.2.2 did not solve this)
It shows up in the page title report on my dashboard as well as the page title report in the actions tab.

I have checked the entire visitor log and the visitors in real time widget. In these reports all pages have a normal page name, there are no instances of 'page name not defined'.

Here is the line:

Page Name not defined   295     86  0%  0s  0%  -
Page X  95  73  26%     3 min 45s   60%     0.91s

It doesn't show statistics for 'time spend on page', 'exit rate' or 'page generation time', which I think is weird as all my other pages have a normal value for these items.

At first I thought that maybe the goals where being tracked as pages, but the number of conversions is lower (173 conversions/clicks by 67 visitors)

After a closer inspection I noticed that the number of outlinks is the same (295 outlinks, 263 unique outlinks).
Looking at the visitor log again, I see nothing out of the ordinary: outlinks have the typical image in front of them.

As I have two separate installs of piwik (one for the live site and one for development), I have checked if both show the same behaviour, and yes after updating both of them to the latest Piwik version: Outlinks are being tracked as internal pages with 'page name not defined' on both installs.

I hope there is a quick fix for this.

@mattab
Copy link
Member

mattab commented May 9, 2014

Thanks for the report, that's a regression in 2.2.2

@mattab
Copy link
Member

mattab commented May 14, 2014

In 1bf9a20: Refs #5113 This may fix the bug where Outlinks are marked as "Page name not defined".
Let's see which integration tests now fail

@mattab
Copy link
Member

mattab commented May 14, 2014

In dec86d0: Fixes #5113 Updating integration test after the bug was fixed!

@anonymous-matomo-user anonymous-matomo-user added this to the 2.3.0 - Piwik 2.3.0 milestone Jul 8, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
…s "Page name not defined".

Let's see which integration tests now fail
@bbbart
Copy link

bbbart commented Jun 17, 2018

Since two days the page views on a site I'm tracking with Matomo 3.5.1 seemingly tripled. Great was my surprise when I saw that this increase was mainly accountable to a page with the title 'Page Name not defined'.

Just like I read here, this phantom page gets views and unique views, but no other stats (either '0' or '-').

Last Friday I did make a change however: I minified the HTML, CSS and JS resources on my website. But the Matomo installation remained untouched.

Any pointers to help me figure out what is going wrong here?

@steffenr
Copy link

@bbbart Could you solve your issues 2 years ago? What was the problem - right now we have similar problems with "Page Name not defined". Thx for answering.

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Bug For errors / faults / flaws. Major Indicates the severity or impact or benefit of an issue is much higher than normal but not critical.
Projects
None yet
Development

No branches or pull requests

4 participants