Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Set Base URL used in the AJAX request to ? instead of index.php? #5127

Closed
anonymous-matomo-user opened this issue May 9, 2014 · 5 comments
Closed
Assignees
Labels
Bug For errors / faults / flaws.
Milestone

Comments

@anonymous-matomo-user
Copy link

from a version 2.2.2 install on a shared hosting linux server.

if I click 'all websites' it gives an error message:
You can't access this resource as it requires an 'view' access for the website id = 1.

if I try to save something in 'user settings' an error messages says: Token is not valid.

in short, nothing saves on any page.

this is straight after a standard install with only the optional fields mail and load data infile showing as not working in the System Check screen.

@mattab
Copy link
Member

mattab commented May 13, 2014

In 6abc39d: Trying to set module + method as GET parameters to overwrite any existing GET param. Refs #5127
To test:

  • apply this patch
  • delete piwik/tmp/assets/*
  • try again if it's working?

@mattab
Copy link
Member

mattab commented May 13, 2014

In 497f6da: Refs #5127 revert previous commit as this was not the fix
Thanks for sending me access to the server so I could check myself

@mattab
Copy link
Member

mattab commented May 13, 2014

In 5ada2b9: Fixes #5127 Set Base URL used in the AJAX request to ? instead of index.php?

It is set to '?' rather than 'index.php?' to increase chances that it works
including for users who have an automatic 301 redirection from index.php? to ?
POST values are missing when there is such 301 redirection. So by by-passing
this 301 redirection, we avoid this issue.

@anonymous-matomo-user
Copy link
Author

thank you for looking at this so promptly. is there a version number I should look out for that this update will be applied to?

@mattab
Copy link
Member

mattab commented May 19, 2014

@turbo_bob please upgrade to latest beta version: http://piwik.org/faq/how-to-update/faq_159/

@anonymous-matomo-user anonymous-matomo-user added this to the 2.3.0 - Piwik 2.3.0 milestone Jul 8, 2014
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
…ting GET param. Refs matomo-org#5127

To test:
- apply this patch
- delete piwik/tmp/assets/*
- try again if it's working?
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
Thanks for sending me access to the server so I could check myself
sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
…stead of `index.php?`

 It is set to '?' rather than 'index.php?' to increase chances that it works
 including for users who have an automatic 301 redirection from index.php? to ?
 POST values are missing when there is such 301 redirection. So by by-passing
 this 301 redirection, we avoid this issue.
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Bug For errors / faults / flaws.
Projects
None yet
Development

No branches or pull requests

2 participants