New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Marketplace Plugins ZIP file cannot be decompressed on some systems (eg. Windows) #6538

Closed
mattab opened this Issue Oct 28, 2014 · 2 comments

Comments

Projects
None yet
2 participants
@mattab
Member

mattab commented Oct 28, 2014

The goal of this issue is to change the way we build the plugins ZIP file in the Marketplace so that the ZIP can safely decompress on all machines.

This issue has been reported by several users

  • Windows (win zip 7) fails to decompress the zip http://forum.piwik.org/read.php?2,121392
  • On Linux / Ubuntu, when I open the ZIP using Archiver I only see a directory called . instead of the expected "CustomAlerts" root directory. See screenshot:

directory-name-is-dot

Reproduce

Expected:

  • First directory in the ZIP is the plugin name instead of .
  • Should decompress fine on Windows (likely this is because the directory is called . that on windows it does not decompress)

@mattab mattab added Task Bug c: Marketplace and removed Task labels Oct 28, 2014

@mattab mattab added this to the Short term milestone Oct 28, 2014

@mattab mattab modified the milestones: Mid term, Short term Apr 7, 2015

@mattab mattab modified the milestones: Long term, Mid term Dec 5, 2016

@mattab

This comment has been minimized.

Member

mattab commented Mar 7, 2017

Got some report from user that the ZIPs are marked as spam by gmail. I think this may be due to the same problem. Also some users/customers get confused that the zip appears empty on windows. On Ubuntu for example the ZIP first visible level is a directory called . which is confusing.

It would be great to address this in the Marketplace!

@mattab mattab modified the milestones: 3.0.3, Backlog (Help wanted) Mar 7, 2017

@sgiehl sgiehl self-assigned this Mar 25, 2017

@mattab mattab closed this Mar 27, 2017

mattab added a commit to mattab/piwik-plugin-ApiGetWithSitesInfo that referenced this issue Mar 27, 2017

@mattab

This comment has been minimized.

Member

mattab commented Mar 27, 2017

This bug has been fixed after 2.5 years 👍 Good times. Working ZIP can be seen at: https://plugins.piwik.org/api/2.0/plugins/ApiGetWithSitesInfo/download/0.1.6

Note: it's only fixed for plugins that we will release in the future from now on

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment